Search found 578 matches

Return to advanced search

Re: Check_VMWARE_API Plugin not working

root@tgcs017:/usr/local/nagios/libexec# perl -MLWP -e 'print "$LWP::VERSION\n"';
6.15

root@tgcs017:/usr/bin# vmware-cmd --version
vSphere SDK for Perl version: 6.5.0
Script 'vmware-cmd' version: 6.5.0
by kwhogster
Wed Apr 10, 2019 9:36 pm
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627

Re: Check_VMWARE_API Plugin not working

root@tgcs017:/usr/local/nagios/libexec# ./check_vmware_api.pl -H TGCSESXI-1 -u root -p "##########" -l runtime -t 200 Use of uninitialized value $subcommand in string ne at ./check_vmware_api.pl line 1899. CHECK_VMWARE_API.PL OK - 4/15 VMs up, overall status=green, connection state=connect...
by kwhogster
Tue Apr 09, 2019 6:30 pm
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627

Re: Check_VMWARE_API Plugin not working

Thanks

Sorry for the delay been sick lately.

Here it is

check_vmware_api.pl
check_vmware_api.pl
(166.42 KiB) Downloaded 128 times



FYI.
It did start working on Saturday but is back again today with same error

Thanks again
by kwhogster
Tue Apr 09, 2019 7:21 am
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627

Re: Check_VMWARE_API Plugin not working

root@tgcs017:~# dpkg -l | grep libwww-perl ii libwww-perl 6.15-1 all simple and consistent interface to the world-wide web root@tgcs017:~# cpan -a | grep libwww-perl LWP 6.15 6.38 OALDERS/libwww-perl-6.38.tar.gz LWP::Authen::Basic undef 6.38 OALDERS/libwww-perl-6.38.tar.gz LWP::Authen::Digest undef ...
by kwhogster
Fri Apr 05, 2019 7:32 pm
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627

Re: Check_VMWARE_API Plugin not working

Is this the same version of ESXi/VSphere server as the rest of them (that are working)? Yes all but one I have 9 ESXI hosts 8 6.5 1 6.0 This is an ESXI 6.5 Host having the issue all other hosts work great. Are the permissions of the user the same? Yes same userid Root and same password I logon to ea...
by kwhogster
Fri Apr 05, 2019 1:45 pm
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627

Re: Check_VMWARE_API Plugin not working

That worked great Have one issue on one ESXI Host Host: TGCSESXI-1 Service: ESXI VMFS Check Status: CRITICAL Last check: 04-05-2019 10:33:26 Duration: 0d 10h 37m 11s Attempt: 3/3 Status information: (Service check timed out after 120.01 seconds) run this ./check_vmware_api.pl -H TGCSESXI-1 -u root -...
by kwhogster
Fri Apr 05, 2019 10:12 am
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627

Re: Check_VMWARE_API Plugin not working

I found two places line 31 and line 99

I then tested all the command on all my hosts

All worked but one the VMFS check line 812 was another one.

My search ability in VI is not the best I am a Windows GUY LOL



Do you know of any other places in the script I may need to change?
by kwhogster
Fri Mar 15, 2019 1:55 pm
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627

Re: Check_VMWARE_API Plugin not working

root@tgcs017:/usr/local/nagios/libexec# cat /proc/sys/kernel/random/entropy_avail 170 The other check gives this error root@tgcs017:/usr/local/nagios/libexec# ./check_esx3.pl Can't locate Nagios/Plugin.pm in @INC (you may need to install the Nagios::Plugin module) (@INC contains: /etc/perl /usr/loca...
by kwhogster
Fri Mar 15, 2019 1:27 pm
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627

Re: Check_VMWARE_API Plugin not working

1, yes the checked worked the first time on myhost-3 now it timesout. 2. I ran this against all my hosts I have 9 of them to see if it worked all the same timeout. 3. root@tgcs017:/usr/local/nagios/etc/objects/linuxservers# nmap myhost-2 -p 443 Starting Nmap 7.01 ( https://nmap.org ) at 2019-03-15 1...
by kwhogster
Fri Mar 15, 2019 11:10 am
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627

Re: Check_VMWARE_API Plugin not working

root@tgcs017:/usr/local/nagios/libexec# ./check_vmware_api.pl -H myhost-2 -t 50 -u root -p "#########" -l runtime -s status -vvv [extra-opts] check_vmware_api.pl -H muhost-2 -t 50 -u root -p ##My95hog -l runtime -s status -vvv CHECK_VMWARE_API.PL UNKNOWN - plugin timed out (timeout 50s) ro...
by kwhogster
Fri Mar 15, 2019 10:18 am
 
Forum: Nagios Core
Topic: Check_VMWARE_API Plugin not working
Replies: 39
Views: 2627
Next

Return to advanced search