Commercial Support Clients: Clients with support contracts can get escalated support assistance by visiting Nagios Answer Hub. These forums are for community support services. Although we at Nagios try our best to help out on the forums here, we always give priority support to our support clients.

Bug? Empty/blank screen in NCPA Configuration Wizard

This support forum board is for support questions relating to Nagios XI, our flagship commercial network monitoring solution.

Bug? Empty/blank screen in NCPA Configuration Wizard

Postby arthurf » Sat Feb 04, 2023 9:25 am

Hello everyone,

I would like to create an IT environment to be monitored with NagiosXI for my IT graduation project. Unfortunately I encountered a problem while configuring this and it looks more like a NagiosXI error/bug to me.

The NagiosXI server is running on a ESXI 6.7 Host as a virtual machine (Vmware OVA pre-configured virtual machine Version 5.9.3).
There are also two virtual windows servers running on the hypervisor (2x Windows Server 2019).
I have decided to monitor the virtual machines over the NCPA Agent (Agent NCPA 2.4.0). I installed the agents after a nagios youtube tutorial and didn't change the settings. The binding ip is also "".

However, when I try to add the two servers to NagiosXI (Configure -> Start Monitoring Now -> Setup NCPA ), after specifying the IP and token, only a blank/empty/white page comes up. Visible in the attached screenshot. https://localhost:5693 is also working on both windows machines!
I can also successfully establish a connection to the ncpa agents on the windows servers with telnet via another device in the network.
The local windows firewall doesn't cause any problems either, since I released the ports (5693 TCP+UDP incoming & outgoing) and even deactivated the firewall completely for testing. This is definitely a backend problem.

I found forum entries on the internet where the problem is known and tried to solve the problem with the instruction.
Unfortunately, this didn't help me either. (https://www.skynats.com/blog/fixing-emp ... in-nagios/)

Maybe someone here knows how to solve the problem. I'll write a short list of what I've already tried.
Many thanks in advance and greetings from Germany
- Arthurf

List of tried things:
- restarted NagiosXI + Servers
- testing other OVAs from the Nagios Website (Windows + Vmware)
- testing with/without HTTPS setting
- typing in the IP-adress into NagiosXI in CIDR
- installing older NCPA Agents
- remove and add components & wizards (component-backendiurl, configwizard.ncpa)
- same environment replicated and installed on VMware Workstation Pro 16
- tried other browsers
- cleared cache on browsers
- deactivated adblocker on browser
You do not have the required permissions to view the files attached to this post.
Posts: 2
Joined: Sat Feb 04, 2023 7:47 am

Re: Bug? Empty/blank screen in NCPA Configuration Wizard

Postby arthurf » Sat Feb 04, 2023 9:49 am

Thread "Bug found in latest OVA from Nagios XI Download Page" is the same issue.
Does anyone have a download link for an older NagiosXI VMware ova. version?
Posts: 2
Joined: Sat Feb 04, 2023 7:47 am

Return to Nagios XI

Who is online

Users browsing this forum: Google [Bot] and 28 guests