z

Commercial Support Clients: Clients with support contracts can get escalated support assistance by visiting Nagios Answer Hub. These forums are for community support services. Although we at Nagios try our best to help out on the forums here, we always give priority support to our support clients.

Object does not exist yet shown on GUI

This support forum board is for support questions relating to Nagios XI, our flagship commercial network monitoring solution.

Object does not exist yet shown on GUI

Postby apteancloud » Fri Nov 12, 2021 5:56 am

Hi,

One of my colleagues have setup a new host and services yesterday, where one of the services was not properly setup and he had deleted it and applied configuration. Yet the said service is reflected on GUI.
GUI.JPG

When I tried to review the service in GUI, it shows to be present.
ServiceCheck.JPG

I have also checked in CCM and it doesn't list there either. Not sure why is the stale entry still present. I have tried to apply configuration multiple time as well along with restarting the Monitoring Engine.
CCM.JPG

Please assist.
You do not have the required permissions to view the files attached to this post.
apteancloud
 
Posts: 47
Joined: Wed Sep 09, 2020 4:05 am

Re: Object does not exist yet shown on GUI

Postby ssax » Fri Nov 12, 2021 2:29 pm

Please go to Configure > Core Config Manager > Tools > Config File Management:
- Click the Delete Files button (don't worry, it's safe, they will be rewritten)
- Then click the Write Configs button
- Once they are done being written, apply configuration and see if it has been removed.

That alone may fix it.

It it still shows up, please PM me a copy of your profile.zip, you can download it from Admin > System Profile by clicking the Download Profile button.
ssax
Dreams In Code
 
Posts: 7682
Joined: Wed Feb 11, 2015 12:54 pm

Re: Object does not exist yet shown on GUI

Postby apteancloud » Mon Nov 15, 2021 8:19 am

I did 'Delete Files' and then 'Write Configs', followed by 'Verify Files' and I get this error.
Verify.JPG

On 'Restart Nagios Core', I get this:
Restart.JPG

Please advise.
You do not have the required permissions to view the files attached to this post.
apteancloud
 
Posts: 47
Joined: Wed Sep 09, 2020 4:05 am

Re: Object does not exist yet shown on GUI

Postby ssax » Mon Nov 15, 2021 4:23 pm

You can revert to a good config snapshot in Admin > Config Snapshots and then apply configuration.

I'm able to replicate it with your imported DB from the profile.zip, it looks like the _mutliple_hosts ones are having issues. Was an import recently done?
ssax
Dreams In Code
 
Posts: 7682
Joined: Wed Feb 11, 2015 12:54 pm

Re: Object does not exist yet shown on GUI

Postby apteancloud » Mon Nov 15, 2021 11:14 pm

Considering the issue started on Nov 11, 2021 and its been 5 days since, should I do config snapshots before Nov 11, 2021?
This is what I see for Config Snapshots at present:
CS.JPG


If the answer to above is 'need not be' and I can rollback to a good configuration after Nov 11, 2021, let's presume Nov 16, 2021, do I risk of losing data that was added after Nov 11, 2021 till the point of revert?
You do not have the required permissions to view the files attached to this post.
apteancloud
 
Posts: 47
Joined: Wed Sep 09, 2020 4:05 am

Re: Object does not exist yet shown on GUI

Postby ssax » Tue Nov 16, 2021 3:20 pm

The one from 11-16 at the top doesn't show as red, I'd just click restore on that one then go to Configure > Core Config Manager > Tools > Config File Manage and do a Delete/Write, then try to Apply Configuration.

If you still have issues, please create a ticket for this and include a link back to this forum thread so we can get a remote session setup:

https://support.nagios.com/tickets/

The other ones shown in red will have issues if you restore from them.
ssax
Dreams In Code
 
Posts: 7682
Joined: Wed Feb 11, 2015 12:54 pm

Re: Object does not exist yet shown on GUI

Postby apteancloud » Mon Nov 29, 2021 9:45 pm

Ticket was opened on 24/Nov, yet no response on the ticket. I presume that is due to Thanksgiving. Can the ticket be looked at now please?
apteancloud
 
Posts: 47
Joined: Wed Sep 09, 2020 4:05 am

Re: Object does not exist yet shown on GUI

Postby ssax » Tue Nov 30, 2021 12:15 pm

Locking thread, ticket received, we will continue support through the ticket (I sent a response in the ticket).

Thank you!
ssax
Dreams In Code
 
Posts: 7682
Joined: Wed Feb 11, 2015 12:54 pm


Return to Nagios XI

Who is online

Users browsing this forum: Google [Bot] and 25 guests