z

Commercial Support Clients: Clients with support contracts can get escalated support assistance by visiting Nagios Answer Hub. These forums are for community support services. Although we at Nagios try our best to help out on the forums here, we always give priority support to our support clients.

stderr:"/usr/local/nagios/libexec/check_nna.py", line 159

This support forum board is for support questions relating to Nagios XI, our flagship commercial network monitoring solution.

stderr:"/usr/local/nagios/libexec/check_nna.py", line 159

Postby bcgriffin90 » Thu Feb 24, 2022 3:29 pm

Linux Distribution and version?

RHEL 8.5

32 or 64bit?

64bit

VMware Image or Manual Install of XI?

Manual

Are there special configurations on your system, ie; is Gnome installed? Are you using a proxy? Are you using SSL?

no


Issue:

I have nagios log, xi, and net analyzer all deployed. They are all installed on their own servers. Each server is functioning. I wanted to setup alerting for the bandwidth data being captured from net analyzer. After reading the docs, I decided to add net analyzer to xi as a component using the api key, and then use the 'nagios network analyzer' configuration wizard to alert based on bytes, flows, and packets.

I'm having two issues.

1) After adding the API key via the net analyzer component, if I navigate to Home > Host Status > any host > Network Traffic Analysis... the graph never loads and the tables for summary data and brief data are empty.

2) After adding one of my hosts via the network analyzer configuration wizard... The service checks for 'Bytes, Flows, and Packets' all fail with the same error: (No output on stdout) stderr: File "/usr/local/nagios/libexec/check_nna.py", line 159

Thanks
bcgriffin90
 
Posts: 14
Joined: Mon Dec 20, 2021 2:46 pm

Re: stderr:"/usr/local/nagios/libexec/check_nna.py", line 15

Postby ssax » Fri Feb 25, 2022 3:41 pm

First, we need to make sure everything is using the same protocols:

When you are accessing the Nagios XI web interface, do you see https:// in the URL in the web browser address bar?

When you are accessing the Nagios Network Analyzer web interface, do you see https:// in the URL in the web browser address bar?

If the answer to either of those questions is YES then ALL of them need to be using https so that your web browser doesn't block it because of CORS (blocking mixed http and https content because it can leak information).

Please PM me a copy of your profile.zip from the XI server from Admin > System Profile > Download Profile button.

From the XI server, PM me what you have set in Admin > Program URL AND also PM me a screenshot of your settings in Admin > Manage Components > Nagios Network Analyzer Integration > Settings.

If they are use https, PM the output of this one from the XI server:
- NOTE: You would use the exact your_network_analyzer_server_name that you have set on the XI server Admin > Manage Components > Nagios Network Analyzer Integration > Settings in the command below before running

Code: Select all
curl -k -L -vvv 'https://your_network_analyzer_server_name/networkanalyzer/'
openssl s_client -showcerts -connect your_network_analyzer_server_name:443


It's also good to check from the other end as well (from NNA to the XI server) with what your XI server has set in Admin > System Settings > Program URL:

Code: Select all
curl -k -L -vvv 'https://your_xi_server_name/nagiosxi/'
openssl s_client -showcerts -connect your_xi_server_name:443
ssax
Dreams In Code
 
Posts: 7682
Joined: Wed Feb 11, 2015 12:54 pm

Re: stderr:"/usr/local/nagios/libexec/check_nna.py", line 15

Postby bcgriffin90 » Wed Mar 02, 2022 1:47 pm

Ssax, I tried to reply you via PM, but my PM is stuck in my outbox. The message is not listed under sent, and it's been sitting in my outbox since Monday. Can you help me with what I'm doing wrong?
bcgriffin90
 
Posts: 14
Joined: Mon Dec 20, 2021 2:46 pm

Re: stderr:"/usr/local/nagios/libexec/check_nna.py", line 15

Postby gsmith » Thu Mar 03, 2022 3:04 pm

Hi,

ssax had to step away to take care of a personal matter.

If the pm isn't working can you please send the results via email? gsmith@nagios.com

If that doesn't work for you please let me know and we can find an alternative solution.

Thanks
gsmith
 
Posts: 1253
Joined: Tue Mar 02, 2021 11:15 am

Re: stderr:"/usr/local/nagios/libexec/check_nna.py", line 15

Postby bcgriffin90 » Tue Mar 15, 2022 8:16 am

Good Morning, I sent you an email a few days ago. Is there any updates on this issue?

Thank you!
Colton
bcgriffin90
 
Posts: 14
Joined: Mon Dec 20, 2021 2:46 pm

Re: stderr:"/usr/local/nagios/libexec/check_nna.py", line 15

Postby gsmith » Tue Mar 22, 2022 10:33 am

Hi

I am so sorry this one got lost in the cracks - I never received an email.

Can you please try resending the email to me (gsmith@nagios.com) ?

Thank you
gsmith
 
Posts: 1253
Joined: Tue Mar 02, 2021 11:15 am

Re: stderr:"/usr/local/nagios/libexec/check_nna.py", line 15

Postby bcgriffin90 » Tue Mar 22, 2022 2:35 pm

I just re-sent it.

thank you.
bcgriffin90
 
Posts: 14
Joined: Mon Dec 20, 2021 2:46 pm

Re: stderr:"/usr/local/nagios/libexec/check_nna.py", line 15

Postby gsmith » Wed Mar 23, 2022 12:15 pm

Hi

The problem is that the check_nna.py plugin works with python2 but not python3. Here is a
workaround:

1. on the XI server install python2 if it isn't already there (yum install python2)
2. run ln -s /usr/bin/python3 /usr/bin/python
3. change the command for check_xi_nna from:
nna_orig_cmd.png

to:
nna_new_cmd.png

4. Apply Configuration and you should be all set

Please let me know if you run into any issues.

Thanks
You do not have the required permissions to view the files attached to this post.
gsmith
 
Posts: 1253
Joined: Tue Mar 02, 2021 11:15 am

Re: stderr:"/usr/local/nagios/libexec/check_nna.py", line 15

Postby bcgriffin90 » Wed Mar 30, 2022 8:21 am

Good Morning,

My sym link was already set up the way you described. I updated the command within the gui, applied the configuration, and even rebooted the server. I'm now receiving a different error. Also, navigating to the 'network traffic analysis' tab for a given host results in the page spinning indefinitely.

UNKNOWN - Error occurred while running the plugin.

What's our next steps on this?

Thanks,
Colton
bcgriffin90
 
Posts: 14
Joined: Mon Dec 20, 2021 2:46 pm

Re: stderr:"/usr/local/nagios/libexec/check_nna.py", line 15

Postby gsmith » Wed Mar 30, 2022 9:27 am

Hi

Please run this from the command line on the XI server and post the results:
/usr/local/nagios/libexec/check_nna.py -H <ip of NNA server> -K <api key of nna server> -S 8 -m flows -w 10 -c 20 --verbose


Thanks
gsmith
 
Posts: 1253
Joined: Tue Mar 02, 2021 11:15 am

Next

Return to Nagios XI

Who is online

Users browsing this forum: No registered users and 6 guests