z

Commercial Support Clients: Clients with support contracts can get escalated support assistance by visiting Nagios Answer Hub. These forums are for community support services. Although we at Nagios try our best to help out on the forums here, we always give priority support to our support clients.

Not generating hard state on OK alert

This support forum board is for support questions relating to Nagios XI, our flagship commercial network monitoring solution.

Not generating hard state on OK alert

Postby capgemtools » Mon Mar 07, 2022 4:15 pm

Hi Support Team,

We are currently using Nagios XI 5.8.4 version in production(centos 7).
Nagios XI installation was done through OVA.
We have configured services at check interval 5 min, retry interval 5 min and max check attempts is 3.
From service now ticketing tool, we are polling only hard alerts to generate and close ticket.
Recently we have observed that, when a service comes up from down state it does not generate hard state on OK alert. It checks for only once that is soft state of OK alert(where it needs to check thrice so that it generates hard alert) and it does not checks for rest 2 attempts.
Due to which ticket are not auto closing in the service now system as it does not receives HARD state on OK alert from nagios server.
PFA for your reference.

Please help us to resolve this issue.

Thanks & Regards,
Supriya Lad.
You do not have the required permissions to view the files attached to this post.
Thanks,
Supriya
capgemtools
 
Posts: 56
Joined: Wed Aug 12, 2020 3:16 pm

Re: Not generating hard state on OK alert

Postby pbroste » Wed Mar 09, 2022 4:31 pm

Hello @capgemtools

Thanks for reaching out, want to start off by running through reindexing.



Verify that the host and services look good in pre-flight with no errors in core by:
  • Code: Select all
    /usr/local/nagios/bin/nagios -vvv /usr/local/nagios/etc/nagios.cfg


Please PM your updated system profile if the issue persists.

To send us your system profile.
  • Login to the Nagios XI GUI using a web browser.
  • Click the "Admin" > "System Profile" Menu
  • Click the "Download Profile" button
  • Save the profile.zip file and send via Private Message

Thanks,
Perry
User avatar
pbroste
 
Posts: 1287
Joined: Tue Jun 01, 2021 1:27 pm

Re: Not generating hard state on OK alert

Postby capgemtools » Thu Mar 10, 2022 10:39 am

Hi Perry,

I have follwed the steps mentioned by you but see no errors.
Sharing you system profile via private message.
Currently we are on NagiosXI 5.8.4, so do we have to upgrade to latest version?

Thanks,
Supriya.
Thanks,
Supriya
capgemtools
 
Posts: 56
Joined: Wed Aug 12, 2020 3:16 pm

Re: Not generating hard state on OK alert

Postby pbroste » Wed Mar 16, 2022 1:56 pm

Hello @capgemtools

Thanks for following up and sending over the System Profile did not see anything that sticks out. Want to run through reindex and let us know how things look.

To reindex the Core Configuration Manager (CCM) configs by:



    • Code: Select all
      rm -rf /usr/local/nagios/etc/import/*

    • Code: Select all
      /usr/local/nagiosxi/scripts/reconfigure_nagios.sh

    Verify that the host and services look good and verify that there are no errors in core by:

    • Code: Select all
      /usr/local/nagios/bin/nagios -vvv /usr/local/nagios/etc/nagios.cfg


    Issue persists, please PM your system profile for us to review updates.

    To send us your system profile.
    • Login to the Nagios XI GUI using a web browser.
    • Click the "Admin" > "System Profile" Menu
    • Click the "Download Profile" button
    • Save the profile.zip file and send as Private Message

Thanks,
Perry

p.s.
We're moving to a new support system!

The Nagios Answer Hub is a place where you can get help with technical questions from our experts. There, you can quickly open tickets and join discussion boards.

Request Nagios Answer Hub access here: https://info.nagios.com/answer-hub-access-new-users

After completing the access form, you will be given access to a portal where new tickets can be created. We will keep the old customer forum sections and ticket system available for current cases to be resolved.
User avatar
pbroste
 
Posts: 1287
Joined: Tue Jun 01, 2021 1:27 pm

Re: Not generating hard state on OK alert

Postby capgemtools » Tue Apr 05, 2022 11:05 am

Hi Perry,

I have followed steps mentioned by you but there are no errors.
Does it require us to upgrade nagiosxi to latest version to resolve this issue?
Thanks,
Supriya
capgemtools
 
Posts: 56
Joined: Wed Aug 12, 2020 3:16 pm

Re: Not generating hard state on OK alert

Postby pbroste » Tue Apr 05, 2022 4:06 pm

Hello @capgemtools

Thanks for following up and yes you are correct that an environment upgrade is highly suggested. Let's go ahead with the upgrade and have you open a new support ticket in the new Answer Hub.

We're moving to a new support system!

The Nagios Answer Hub is a place where you can get help with technical questions from our experts. There, you can quickly open tickets and join discussion boards.

Request Nagios Answer Hub access here: https://info.nagios.com/answer-hub-access-new-users

After completing the access form, you will be given access to a portal where new tickets can be created. We will keep the old customer forum sections and ticket system available for current cases to be resolved.


Please let us link back to this support forum post so we can review the case details.

Thanks
Perry
User avatar
pbroste
 
Posts: 1287
Joined: Tue Jun 01, 2021 1:27 pm


Return to Nagios XI

Who is online

Users browsing this forum: Google [Bot] and 8 guests