Page 1 of 1

Unable to access the Nagios web interface in Localhost

PostPosted: Mon Nov 28, 2022 7:20 am
by PaulRajeshMEzra45
i installed Nagios core in my local system I have followed the Link to install it but I am unable to access the web interface i am getting the following error

// Allow specifying main window URL for permalinks, etc.
$url = 'main.php';

if ("no" == "yes" && isset($_GET['corewindow'])) {

// The default window url may have been overridden with a permalink...
// Parse the URL and remove permalink option from base.
$a = parse_url($_GET['corewindow']);

// Build the base url.
$url = htmlentities($a['path']).'?';
$url = (isset($a['host'])) ? $a['scheme'].'://'.$a['host'].$url : '/'.$url;

$query = isset($a['query']) ? $a['query'] : '';
$pairs = explode('&', $query);
foreach ($pairs as $pair) {
$v = explode('=', $pair);
if (is_array($v)) {
$key = urlencode($v[0]);
$val = urlencode(isset($v[1]) ? $v[1] : '');
$url .= "&$key=$val";
if (preg_match("/^http:\/\/|^https:\/\/|^\//", $url) != 1)
$url = "main.php";

$this_year = '2018';
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "">

<meta name="ROBOTS" content="NOINDEX, NOFOLLOW">
<title>Nagios: <?php echo $_SERVER['SERVER_NAME']; ?></title>
<link rel="shortcut icon" href="images/favicon.ico" type="image/ico">

<script LANGUAGE="javascript">
var n = Math.round(Math.random() * 10000000000);
document.cookie = "NagFormId=" + n.toString(16);

<frameset cols="180,*" style="border: 0px; framespacing: 0px">
<frame src="side.php" name="side" frameborder="0" style="">
<frame src="<?php echo $url; ?>" name="main" frameborder="0" style="">

<!-- This page requires a web browser which supports frames. -->
<h2>Nagios Core</h2>
<p align="center">
<a href=""></a><br>
Copyright &copy; 2010-<?php echo $this_year; ?> Nagios Core Development Team and Community Contributors.
Copyright &copy; 1999-2010 Ethan Galstad<br>
<i>Note: These pages require a browser which supports frames</i>

I already worked on Nagios Core recently, I tried to install Nagios Xi in my local system which I couldn't for some issue, since then I am not able to access Nagios core web interface also Can someone help me how omeglz echat to resolve that issue? Thank you