Error failed to update data....

Information and discussions relating to the Nagios V-Shell web interface.

Re: Error failed to update data....

Postby Kilvador » Tue Oct 17, 2017 7:43 am

kyang wrote:Hi, sorry about that. Didn't have the time to before the week ended.

I tested it out and ran into some errors when using the 2.x link. Not sure, why?

Then I reran the V-Shell install but used the latest version available at
https://github.com/NagiosEnterprises/nagiosvshell

Then it worked just fine. I didn't mess with the index.php file, only with the htpasswd location in the config.php.

Are you able to install the latest version?


All good with this version.

But, there is some errors while setup:

Code: Select all
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /home/kilvador/sources/nagiosvshell/install.php on line 28


Next, I must insert new filename for /etc/nagiosvshell.conf in: /usr/local/nagiosvshell/constants.inc.php (there were old name /etc/vshell.conf)

Next, on the WEB-interface hostgroups and servicegroups are not working - 500 http error.

And finally, here are http errors:

Code: Select all
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 220, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 219, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 218, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 217, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 216, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 215, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 214, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 213, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 212, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 211, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 210, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:56 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 209, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 232, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 231, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 230, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 229, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 228, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 227, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 240, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 97, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /usr/local/nagiosvshell/data/get_tac_data.php on line 81, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: flap_detection_enabled in /usr/local/nagiosvshell/data/get_tac_data.php on line 212, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: is_flapping in /usr/local/nagiosvshell/data/get_tac_data.php on line 213, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: notifications_enabled in /usr/local/nagiosvshell/data/get_tac_data.php on line 214, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: event_handler_enabled in /usr/local/nagiosvshell/data/get_tac_data.php on line 215, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: active_checks_enabled in /usr/local/nagiosvshell/data/get_tac_data.php on line 216, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: passive_checks_enabled in /usr/local/nagiosvshell/data/get_tac_data.php on line 217, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: last_check in /usr/local/nagiosvshell/data/get_tac_data.php on line 222, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=
[Tue Oct 17 15:37:57 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: active_checks_enabled in /usr/local/nagiosvshell/data/get_tac_data.php on line 222, referer: nagiosvshell/index.php?type=services&state_filter=UNHANDLED&name_filter=



My initial config looks like this:

Code: Select all
$ cat ~/sources/nagiosvshell/config.php

$defaults['redhat'] = array(
        'targetdir'      => '/usr/local/nagiosvshell',
        'apacheconfdir'  => '/etc/httpd/conf.d',
        'apacheconffile' => 'nagiosvshell.conf',
        'etc_conf'       => 'nagiosvshell.conf',
        'htpasswd_file'  => '/usr/local/nagios/etc/htpasswd.users',
        'vshell_baseurl' => 'nagiosvshell',
        'nagios_coreurl' => 'nagios',
        'resultlimit'    => '100',
        'lang'           => 'en_GB',
        'TTL'            => '90',
);

Kilvador
 
Posts: 16
Joined: Mon Oct 09, 2017 1:09 am
Location: Russia, PAO MegaFon

Re: Error failed to update data....

Postby kyang » Tue Oct 17, 2017 12:36 pm

I'm going to try and redo the process of the 2.x link.

I'll see what I can spin up, because with the latest version of V-Shell I am able to my hostgroups and servicegroups and everything else.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
kyang
Support Tech
 
Posts: 1792
Joined: Tue Jul 25, 2017 3:35 pm

Re: Error failed to update data....

Postby Kilvador » Wed Oct 18, 2017 12:55 am

kyang wrote:I'm going to try and redo the process of the 2.x link.

I'll see what I can spin up, because with the latest version of V-Shell I am able to my hostgroups and servicegroups and everything else.


Tell me, please, when you've done it and I'll test it.
Kilvador
 
Posts: 16
Joined: Mon Oct 09, 2017 1:09 am
Location: Russia, PAO MegaFon

Re: Error failed to update data....

Postby kyang » Wed Oct 18, 2017 9:55 am

So I tested the 2.x link, and got it to work. I didn't create new directory for mine because I just wanted to see if it worked out of the box, and it does.

I am able to view my hostgroups/servicegroups.

Here is my initial config.

Code: Select all
$defaults['redhat'] = array(
        'targetdir'       => '/usr/local/vshell2',
        'apacheconfdir'   => '/etc/httpd/conf.d',
        'apacheconffile'  => 'vshell2.conf',
        'apacheuser'      => 'apache',
        'apachegroup'     => 'apache',
        'etc_conf'        => 'vshell2.conf',
        'htpasswd_file'   => '/usr/local/nagios/etc/htpasswd.users',
        'vshell_baseurl'  => 'vshell2',
        'nagios_coreurl'  => 'nagios',
        'TTL'             => '90',
        'update_interval' => '90',
        'lang'            => 'en_GB',
);


Can you show us your apache config?
Code: Select all
cat /etc/httpd/conf.d/nagiosvshell.conf
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
kyang
Support Tech
 
Posts: 1792
Joined: Tue Jul 25, 2017 3:35 pm

Re: Error failed to update data....

Postby Kilvador » Thu Oct 19, 2017 1:47 am

kyang wrote:So I tested the 2.x link, and got it to work. I didn't create new directory for mine because I just wanted to see if it worked out of the box, and it does.

I am able to view my hostgroups/servicegroups.

Here is my initial config.

Code: Select all
$defaults['redhat'] = array(
        'targetdir'       => '/usr/local/vshell2',
        'apacheconfdir'   => '/etc/httpd/conf.d',
        'apacheconffile'  => 'vshell2.conf',
        'apacheuser'      => 'apache',
        'apachegroup'     => 'apache',
        'etc_conf'        => 'vshell2.conf',
        'htpasswd_file'   => '/usr/local/nagios/etc/htpasswd.users',
        'vshell_baseurl'  => 'vshell2',
        'nagios_coreurl'  => 'nagios',
        'TTL'             => '90',
        'update_interval' => '90',
        'lang'            => 'en_GB',
);


Can you show us your apache config?
Code: Select all
cat /etc/httpd/conf.d/nagiosvshell.conf



Here you are:

Code: Select all
Alias /nagiosvshell "/usr/local/nagiosvshell"

ServerSignature Off
ServerTokens Prod

<Directory "/usr/local/nagiosvshell">
   Options None
   AllowOverride None

   Order allow,deny
   Allow from all

# Nagios XI 
# AuthName "Nagios Monitor XI"
# AuthType Basic
# AuthUserFile /usr/local/nagios/etc/htpasswd.users
# Nagios Core
   AuthName "Nagios Access"
   AuthType Basic
   AuthUserFile /usr/local/nagios/etc/htpasswd.users
   Require valid-user
</Directory>

Kilvador
 
Posts: 16
Joined: Mon Oct 09, 2017 1:09 am
Location: Russia, PAO MegaFon

Re: Error failed to update data....

Postby kyang » Thu Oct 19, 2017 2:28 pm

It's strange, I'm still trying to come across this issue.

How's your php?

Code: Select all
php -v


Code: Select all
php -m
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
kyang
Support Tech
 
Posts: 1792
Joined: Tue Jul 25, 2017 3:35 pm

Re: Error failed to update data....

Postby Kilvador » Fri Oct 20, 2017 1:34 am

kyang wrote:It's strange, I'm still trying to come across this issue.

How's your php?

Code: Select all
php -v


Code: Select all
php -m


Here you can find it:

Code: Select all
$ php -v
PHP 5.5.38 (cli) (built: Feb 18 2017 08:33:29)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies

$ php -m
[PHP Modules]
bz2
calendar
Core
ctype
curl
date
dom
ereg
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
json
libxml
mhash
mysql
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
zip
zlib

[Zend Modules]
Kilvador
 
Posts: 16
Joined: Mon Oct 09, 2017 1:09 am
Location: Russia, PAO MegaFon

Re: Error failed to update data....

Postby npolovenko » Fri Oct 20, 2017 2:42 pm

Hi, @Kilvador.
I'd would probaly start with defining a timezone in your php.ini:
Code: Select all
[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = America/New_York


With that said, errors in your log file should not be causing 500 http error. Seems like you've got a more serious issue going on.

Did you have your Vshell installed on a clean Nagios Core install? You could potentially save up a lot of time by installing the latest version from here instead:
Code: Select all
https://github.com/NagiosEnterprises/nagiosvshell
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2547
Joined: Mon May 15, 2017 5:00 pm

Re: Error failed to update data....

Postby Kilvador » Tue Oct 24, 2017 9:26 am

npolovenko wrote:Hi, @Kilvador.
I'd would probaly start with defining a timezone in your php.ini:
Code: Select all
[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = America/New_York


With that said, errors in your log file should not be causing 500 http error. Seems like you've got a more serious issue going on.

Did you have your Vshell installed on a clean Nagios Core install? You could potentially save up a lot of time by installing the latest version from here instead:
Code: Select all
https://github.com/NagiosEnterprises/nagiosvshell



After Timezone was set, I've got this messages, when tried to reach hostgroups:

Code: Select all
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 220, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 219, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 218, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 217, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 216, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 215, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 214, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 213, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 212, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 211, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 210, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:32 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 209, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 232, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 231, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 230, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 229, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 228, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 227, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 240, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 97, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 85, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 85, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 86, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 88, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Strict Standards:  Accessing static property NagiosData::$properties as non static in /usr/local/nagiosvshell/data/NagiosData.php on line 89, referer: https://host_ip/nagiosvshell/


And finally:

Code: Select all
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: last_check in /usr/local/nagiosvshell/data/data_utils.php on line 145, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: last_check in /usr/local/nagiosvshell/data/data_utils.php on line 145, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: last_check in /usr/local/nagiosvshell/data/data_utils.php on line 145, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: last_check in /usr/local/nagiosvshell/data/data_utils.php on line 145, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: last_check in /usr/local/nagiosvshell/data/data_utils.php on line 145, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: last_check in /usr/local/nagiosvshell/data/data_utils.php on line 145, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Notice:  Undefined index: last_check in /usr/local/nagiosvshell/data/data_utils.php on line 145, referer: https://host_ip/nagiosvshell/
[Tue Oct 24 17:19:34 2017] [error] [client 10.78.202.135] PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in /usr/local/nagiosvshell/data/data_utils.php on line 31, referer: https://host_ip/nagiosvshell/
Kilvador
 
Posts: 16
Joined: Mon Oct 09, 2017 1:09 am
Location: Russia, PAO MegaFon

Re: Error failed to update data....

Postby dwhitfield » Tue Oct 24, 2017 2:33 pm

In /etc/php.ini. please change the following to the listed numbers (unless the numbers are higher than these):

Code: Select all
max_execution_time = 60
    max_input_time = 120
    memory_limit = 256M


Also, please add the following line:
max_input_vars = 10000

After making these changes you'll need to restart the httpd service:

# service httpd restart

We've seen some issues with people using non-repo versions of PHP on Red Hat. You appear to be using a newer version. Is it possible for you to go back to PHP 5.3.3, at least for testing purposes?
dwhitfield
Former Nagios Staff
 
Posts: 4569
Joined: Wed Sep 21, 2016 10:29 am
Location: NoLo, Minneapolis, MN

PreviousNext

Return to Nagios V-Shell

Who is online

Users browsing this forum: No registered users and 2 guests