Page 1 of 1

Nagios Mobile Acknowledgement issue

PostPosted: Tue Dec 10, 2013 2:21 am
by saffer
Hi,

I have installed Nagios Mobile on our environment, and I have noted, that the 'acknowledgments" page does not work.

Tracing the HTTP logs, I can see that there is a call to an incorrectly pathed js/jquery.mobile-1.0.min.js module.

What is showing is "/jquery.mobile-1.0/jquery.mobile-1.0.min.js " with an error 40 and it should be "/nagiosmobile/jquery.mobile-1.0/jquery.mobile-1.0.min.js "
Any thoughts?

10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /nagiosmobile/js/jquery-1.5.2.min.js HTTP/1.1" 304 -
10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /nagiosmobile/nagiosmobile.css HTTP/1.1" 304 -
10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /nagiosmobile/jquery.mobile-1.0/jquery.mobile-1.0.min.css HTTP/1.1" 304 -
10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /nagiosmobile/jquery.mobile-1.0/jquery.mobile-1.0.min.js HTTP/1.1" 304 -
10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /nagiosmobile/js/nagiosmobile.js HTTP/1.1" 304 -
10.3.186.50 - nagiosadm [10/Dec/2013:09:11:02 +0200] "GET /nagiosmobile/index.php?page=services_1 HTTP/1.1" 200 17967
10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /nagiosmobile?page=problem&host=metbpcprd201&service=Memory HTTP/1.1" 301 289
10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /nagiosmobile/jquery.mobile-1.0/images/ajax-loader.png HTTP/1.1" 304 -
10.3.186.50 - - [10/Dec/2013:09:11:05 +0200] "GET /js/jquery-1.5.2.min.js HTTP/1.1" 304 -
10.3.186.50 - - [10/Dec/2013:09:11:05 +0200] "GET /js/nagiosmobile.js HTTP/1.1" 304 -

10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /jquery.mobile-1.0/jquery.mobile-1.0.min.js HTTP/1.1" 404 1596
10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /nagiosmobile/jquery.mobile-1.0/images/icons-18-white.png HTTP/1.1" 304 -

Re: Nagios Mobile Acknowledgement issue

PostPosted: Tue Dec 10, 2013 11:55 am
by abrist
saffer wrote:10.3.186.50 - - [10/Dec/2013:09:11:05 +0200] "GET /js/jquery-1.5.2.min.js HTTP/1.1" 304 -
10.3.186.50 - - [10/Dec/2013:09:11:05 +0200] "GET /js/nagiosmobile.js HTTP/1.1" 304 -

10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /jquery.mobile-1.0/jquery.mobile-1.0.min.js HTTP/1.1" 404 1596
10.3.186.50 - nagiosadm [10/Dec/2013:09:11:05 +0200] "GET /nagiosmobile/jquery.mobile-1.0/images/icons-18-white.png HTTP/1.1" 304 -

What is really weird is that the jquery script is included with a "relative" path from the header in header.inc.php:
Code: Select all
<link rel="apple-touch-icon" href="nagios.png" />
<link rel="stylesheet" href="nagiosmobile.css" />
<script type='text/javascript' src="js/jquery-1.5.2.min.js"></script>
<link rel="stylesheet" href="jquery.mobile-1.0/jquery.mobile-1.0.min.css" />
<script type='text/javascript' src="jquery.mobile-1.0/jquery.mobile-1.0.min.js"></script>
<script type='text/javascript' src="js/nagiosmobile.js"></script>

Are you sure the file exists and that apache has rights to it?

Re: Nagios Mobile Acknowledgement issue

PostPosted: Thu Feb 27, 2014 1:27 am
by andrikaa
Hello, whenever I try to open anything with Javascript, it will not open. When I click on it nothing happens, it just says Javascript and then whatever page I am on at the bottom left. Do you have any idea what this could be? I have the latest version of Java and everything is enabled. Thank you.

Re: Nagios Mobile Acknowledgement issue

PostPosted: Thu Feb 27, 2014 5:59 pm
by lmiltchev
Just to give you heads up. We are still working on your issue and need a little bit more time for testing. We will get back to you as soon as we have a possible solution.