Page 1 of 2

Nagios Mobile on a large install

PostPosted: Sun Dec 29, 2013 12:41 am
by nagtech2
Hi,

When selecting "Host Problems" the screen returns to the normal logon screen without displaying the hosts problems. If you select "Hosts Down" or Unhandeled" works fine. If you select Service Critical it timesout several times before eventually displaying the information. The message is "The page has become unresponsive" Do you want to close it and has 2 options "wait or ok". If you select wait several times the info will come up after a few minutes. Same is true on all of the service options. Vshell works fine, APC is installed.
Thanks

Re: Nagios Mobile on a large install

PostPosted: Mon Dec 30, 2013 10:40 am
by abrist
Have you tried multiple devices? You mobile device or nagios could be the cause of the timeout. Does it work fine on a workstation browser?

Re: Nagios Mobile on a large install

PostPosted: Mon Dec 30, 2013 4:46 pm
by nagtech2
Does not work on a desktop, same issue. I'm guessing the enviroment is to large for it.
Thanks

Re: Nagios Mobile on a large install

PostPosted: Thu Jan 02, 2014 11:28 am
by abrist
Check the logs. You may have to increase the the php.ini limits.
Code: Select all
tail -25 /var/log/httpd/error_log

Re: Nagios Mobile on a large install

PostPosted: Fri Jan 03, 2014 5:01 pm
by nagtech2
abrist wrote:Check the logs. You may have to increase the the php.ini limits.
Code: Select all
tail -25 /var/log/httpd/error_log

I set the php.ini file in the apache2 folder to 2048M memory limit. What other settings should I look at?, The "Host" section is working but not the "Service" section.
This is running on ubuntu 12.04 and Nagios 4.02 has 12,046 devices plus another 4049 services. Vshell works fine.
Thanks

Re: Nagios Mobile on a large install

PostPosted: Mon Jan 06, 2014 10:47 am
by abrist
What is the output of:
Code: Select all
grep "memory_limit\|max_execution\|max_input" /etc/php.ini

Re: Nagios Mobile on a large install

PostPosted: Wed Jan 08, 2014 3:27 pm
by nagtech2
abrist wrote:What is the output of:
Code: Select all
grep "memory_limit\|max_execution\|max_input" /etc/php.ini


grep "memory_limit\|max_execution\|max_input" /etc/php5/apache2/php.ini
; max_input_time
max_execution_time = 30
max_input_time = 60
;max_input_nesting_level = 64
; max_input_vars = 1000
memory_limit = 1024M
and
grep "memory_limit\|max_execution\|max_input" /etc/php5/cli/php.ini
; max_input_time
max_execution_time = 30
max_input_time = 60
;max_input_nesting_level = 64
; max_input_vars = 1000
memory_limit = -1

Re: Nagios Mobile on a large install

PostPosted: Wed Jan 08, 2014 3:32 pm
by abrist
That looks just fine. You could attempt to double the execution/input values and restart apache . . .

Re: Nagios Mobile on a large install

PostPosted: Wed Jan 08, 2014 3:50 pm
by nagtech2
abrist wrote:That looks just fine. You could attempt to double the execution/input values and restart apache . . .


On which of the 2 ini file?

Thanks

Re: Nagios Mobile on a large install

PostPosted: Wed Jan 08, 2014 3:56 pm
by abrist
Depends which one is being used by apache . . . My guess is this one:
Code: Select all
/etc/php5/apache2/php.ini