Page 1 of 1

Nagios Mobile: Access Denied. No authentication detected

PostPosted: Tue Feb 19, 2019 12:03 pm
by holcomb17
I am working on a personal project on my home server and trying to get Nagios Mobile working. I've installed Nagios Core properly and can get to it by going to https://localhost/nagios3. However, when try to access https://localhost/nagiosmobile - I get the following error:

Code: Select all
Access Denied: No authentication detected.


I've verified the Nagios Apache config file (nagiosmobile_apache.conf) to confirm that it has the proper rules configured and at this point, I'm not sure what else to think of. Also, I have restarted both the nagios and apache services.

Here is the nagiosmobile_apache.conf file (see the bottom section specifically to confirm proper auth configuration):

Code: Select all
#modify this file to fit your apache configuration

Alias /nagiosmobile "/usr/local/nagiosmobile"

<Directory "/usr/local/nagiosmobile">
#  SSLRequireSSL
Options None
AllowOverride None
Order allow,deny
Allow from all

#  Allow from 127.0.0.1

######use the below lines for Nagios XI
# AuthName "Nagios Monitor XI"
#  AuthType Basic
# AuthUserFile /usr/local/nagiosxi/etc/htpasswd.users


######Use the below lines for a SOURCE install of Nagios Core
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /etc/nagios3/htpasswd.users
Require valid-user

</Directory>

Re: Nagios Mobile: Access Denied. No authentication detected

PostPosted: Tue Feb 19, 2019 12:10 pm
by holcomb17
Figured it out. Found the answer in another post: viewtopic.php?f=21&t=47937

Try manually copying the config over with:

cp /tmp/nagiosmobile/nagiosmobile_apache.conf /etc/apache2/sites-enabled/nagiosmobile.conf

and restart the service:

service apache2 restart

Re: Nagios Mobile: Access Denied. No authentication detected

PostPosted: Tue Feb 19, 2019 12:17 pm
by scottwilkerson
Great, glad it is resolved

Locking thread