SSL Handshake error for some monitors not for all

This forum is intended for the discussion of Nagios Core development. Feature requests, patches, bug fixes, and all types of development-related discussions are welcome!

NOTE: The SourceForge.net nagios-devel mailing list has been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

SSL Handshake error for some monitors not for all

Postby mdhinesh » Wed May 17, 2017 9:39 pm

Hi Friends,

As shown in attachment, Nagios is throwing "CHECK_NRPE: Error - Could not complete SSL handshake" for some specific monitors not for all. If i execute the command from Nagios Core server, It is not throwing error.

-bash-4.1$ /usr/local/nagios/libexec/check_nrpe -H XXXXX.YYYYY.com -p 5665 -c check_swap
SWAP OK - 100% free (3999 MB out of 3999 MB) |swap=3999MB;0;0;0;3999
-bash-4.1$

This is momentary issue,If one service is throwing this error, After some time this monitor will be in OK state and some other monitor will throw this error. It is generating lot of false alerts.

Thanks,
Dhinesh
Attachments
nrpe.cfg.txt
(7.33 KiB) Downloaded 19 times
Services Status.PNG
mdhinesh
 
Posts: 7
Joined: Wed Dec 21, 2016 12:15 pm

Re: SSL Handshake error for some monitors not for all

Postby tgriep » Thu May 18, 2017 12:52 pm

The first place to look is in the NRPE troubleshooting guide at the link below so see if you can resolve the issue.
https://assets.nagios.com/downloads/nagiosxi/docs/NRPE-Troubleshooting-and-Common-Solutions.pdf
If it is failing intermittently on the servers or it it failing all of the time on those servers?
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tgriep
Madmin
 
Posts: 5872
Joined: Thu Oct 30, 2014 9:02 am

Re: SSL Handshake error for some monitors not for all

Postby mdhinesh » Thu May 18, 2017 4:21 pm

Hi,

We followed those steps already. It is happening intermittently for some services.

Thanks,
Dhinesh.M
mdhinesh
 
Posts: 7
Joined: Wed Dec 21, 2016 12:15 pm

Re: SSL Handshake error for some monitors not for all

Postby dwhitfield » Thu May 18, 2017 4:29 pm

mdhinesh wrote:It is generating lot of false alerts.


You could increase the time between checks if it is switching on and off. Are the hosts going up and down as well? It sounds to me like a network issue.

Also, do you have anything set up to automatically restart services? Maybe it's failing completely and then being turned back on.

Is the NRPE version the same on working checks versus non-working checks?
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3447
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC


Return to Nagios Core Development

Who is online

Users browsing this forum: No registered users and 2 guests