Nagios map setting issue 4.3.2

This forum is intended for the discussion of Nagios Core development. Feature requests, patches, bug fixes, and all types of development-related discussions are welcome!

NOTE: The SourceForge.net nagios-devel mailing list has been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Nagios map setting issue 4.3.2

Postby jagannathan » Sat Jun 16, 2018 8:16 am

Hello folks,

I need some support immediately in nagios side , I installed nagios version 4.3.2 , After login nagios click map on that right corner map setting option will be there below i pasted the link for that setting option image

download/file.php?id=9374&mode=view

1. Disable Display of Links.
2. Disable Display of Text.
3. Disable Display of Popups.
4. Disallow Resizing of Map .

Layout issue,root node changing also map side won't reflected and
View Status Detail For This Host button also not working.
jagannathan
 
Posts: 19
Joined: Sat Jun 16, 2018 7:21 am

Re: Nagios map setting issue 4.3.2

Postby kyang » Mon Jun 18, 2018 3:55 pm

Could you try upgrading to the latest version of Core? 4.3.4?

Just to see, if it works.

Also, what OS are you on?

Any apache error_logs displayed when going through this issue you found? If so, please post the error_logs.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
kyang
Support Tech
 
Posts: 1792
Joined: Tue Jul 25, 2017 3:35 pm

Re: Nagios map setting issue 4.3.2

Postby jagannathan » Mon Jun 18, 2018 11:14 pm

kyang wrote:Could you try upgrading to the latest version of Core? 4.3.4?

Just to see, if it works.

Also, what OS are you on?

Any apache error_logs displayed when going through this issue you found? If so, please post the error_logs.



Hello Folks ,

-> Below i mentioned Nagios installed OS details and my nagios installed version is 4.3.2 :

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.1 LTS"
NAME="Ubuntu"
VERSION="16.04.1 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.1 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
UBUNTU_CODENAME=xenial
jagannathan
 
Posts: 19
Joined: Sat Jun 16, 2018 7:21 am

Re: Nagios map setting issue 4.3.2

Postby jagannathan » Tue Jun 19, 2018 6:12 am

Hello Folks,

-> As per your suggestion i installed and checked with the Nagios® Core™ Version 4.3.4 there is also same issue reflected, I am using the os "Ubuntu 16.04.1 LTS".

-> After installed the 4.3.4 version i validate with the Ui page setting option ,

Map setting option issues :
1. Root node changes. , 2. Disable Display of Links. , 3. Disable Display of Text. , 4. Disable Display of Popups. , 5. Disallow Resizing of Map. , 6. Layout option change and checked duplicate host name showing twice or thrice in map and 7. select particular root node in the map setting option and give View Status Detail For This Host : (Service Status Details For Host 'undefined') .
.

-> That verified setting option UI popup and Service Status Details For Host 'undefined' error also attached in this post . Image name is Nagios_4.3.4_map_setting_issue.png and View_Status_Detail_For_This_Host.png.

-> Any apache error_logs displayed when going through this issue you found? If so, please post the error_logs?

apache error_logs were it should be , i need to install any other seperate package for getting this apache logs.
Attachments
View_Status_Detail_For_This_Host.png
View Status Detail For This Host : Service Status Details For Host 'undefined'
View_Status_Detail_For_This_Host.png (6.79 KiB) Viewed 215 times
Nagios_4.3.4_map_setting_issue.png
Map Setting Option UI popup
Nagios_4.3.4_map_setting_issue.png (7.62 KiB) Viewed 215 times
jagannathan
 
Posts: 19
Joined: Sat Jun 16, 2018 7:21 am

Re: Nagios map setting issue 4.3.2

Postby scottwilkerson » Tue Jun 19, 2018 1:18 pm

Are you logging in as a user that has rights to see anything?

Maybe it's just me but I don't understand what you are seeing that is the problem with the nagios map, and I'm not seeing undefined anywhere.

If you don't have access to the apache error logs on the system it will be impossible to detect if you are missing a php package
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 10514
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Nagios map setting issue 4.3.2

Postby jagannathan » Wed Jun 20, 2018 5:40 am

Hello folks,

-> in nagios after login ui page map setting option popups issues :

1. On select the layout in map setting option snap pasted below :
Layout.png
layout option snap
Layout.png (9.4 KiB) Viewed 191 times


1.1. After select the layout option checked in the map , layout showing twice or thrice for same host name below i pasted the snap of the particular layout option issue:
Layout_1.png
layout showing twice or thrice for same host name


->Give a suggestion to fixing this issue .
jagannathan
 
Posts: 19
Joined: Sat Jun 16, 2018 7:21 am

Re: Nagios map setting issue 4.3.2

Postby jagannathan » Wed Jun 20, 2018 5:55 am

Hello Folks,

> in nagios after login ui page map setting option popups issues :

2. On select the Root node in map setting option snap pasted below :
Root_Node.png
Root node in map setting option
Root_Node.png (9.83 KiB) Viewed 190 times


2.1 After select the root node checked in the map , that select root node is not showing the map it showing always 1st selected root node,below i pasted the corresponding snap :
Root_Node_1.png
root node checked in the map issue
jagannathan
 
Posts: 19
Joined: Sat Jun 16, 2018 7:21 am

Re: Nagios map setting issue 4.3.2

Postby jagannathan » Wed Jun 20, 2018 6:16 am

Hello Folks,

-> After login the nagios ui page select map settting option root node after apply, and then view status details for this host option click snap i pasted below.
status_details.png
view status details for this host option
status_details.png (8.25 KiB) Viewed 190 times


-> in map view status details for this host option select means it will shown the that particular selected root node details but it shown "undefined",below i pasted the snap.
view_status_button_issue.png
view status details for this host option select
view_status_button_issue.png (7.9 KiB) Viewed 190 times
jagannathan
 
Posts: 19
Joined: Sat Jun 16, 2018 7:21 am

Re: Nagios map setting issue 4.3.2

Postby scottwilkerson » Wed Jun 20, 2018 8:41 am

jagannathan wrote:Hello Folks,

> in nagios after login ui page map setting option popups issues :

2. On select the Root node in map setting option snap pasted below :
Root_Node.png


2.1 After select the root node checked in the map , that select root node is not showing the map it showing always 1st selected root node,below i pasted the corresponding snap :
Root_Node_1.png


this is default behavior
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 10514
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Nagios map setting issue 4.3.2

Postby scottwilkerson » Wed Jun 20, 2018 8:46 am

jagannathan wrote:Hello Folks,

> in nagios after login ui page map setting option popups issues :

2. On select the Root node in map setting option snap pasted below :
Root_Node.png


2.1 After select the root node checked in the map , that select root node is not showing the map it showing always 1st selected root node,below i pasted the corresponding snap :
Root_Node_1.png


there is a bug already reported on this issue here
https://github.com/NagiosEnterprises/na ... issues/471
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 10514
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Next

Return to Nagios Core Development

Who is online

Users browsing this forum: No registered users and 2 guests