Configure make nagios-plugins-release-2.2.1 AIX 7.1

This forum is intended for the discussion of Nagios plugin development. Feature requests, patches, bug fixes, and all types of development-related discussions are welcome!

NOTE: The SourceForge.net nagiosplug-devel mailing list has been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby hightowerki » Wed Feb 21, 2018 8:00 am

Hello,

i tried to Compile nagios-plugins-release-2.2.1 on a AIX 7100-03-04-1441. But i run into a Error. Maybe someone can help me. Here is what i executed:
./tools/setup
./configure --prefix=/apps/nrpe
make

Here is the last output from the make:

depbase=`echo idpriv-droptemp.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT idpriv-droptemp.o -MD -MP -MF $depbase.Tpo -c -o idpriv-droptemp.o idpriv-droptemp.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo localcharset.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT localcharset.o -MD -MP -MF $depbase.Tpo -c -o localcharset.o localcharset.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo glthread/lock.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT glthread/lock.o -MD -MP -MF $depbase.Tpo -c -o glthread/lock.o glthread/lock.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo malloca.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT malloca.o -MD -MP -MF $depbase.Tpo -c -o malloca.o malloca.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo math.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT math.o -MD -MP -MF $depbase.Tpo -c -o math.o math.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo safe-read.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT safe-read.o -MD -MP -MF $depbase.Tpo -c -o safe-read.o safe-read.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo sockets.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT sockets.o -MD -MP -MF $depbase.Tpo -c -o sockets.o sockets.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo sys_socket.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT sys_socket.o -MD -MP -MF $depbase.Tpo -c -o sys_socket.o sys_socket.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo glthread/threadlib.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT glthread/threadlib.o -MD -MP -MF $depbase.Tpo -c -o glthread/threadlib.o glthread/threadlib.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo unistd.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT unistd.o -MD -MP -MF $depbase.Tpo -c -o unistd.o unistd.c && mv -f $depbase.Tpo $depbase.Po
depbase=`echo wctype-h.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I.. -D_THREAD_SAFE -g -O2 -MT wctype-h.o -MD -MP -MF $depbase.Tpo -c -o wctype-h.o wctype-h.c && mv -f $depbase.Tpo $depbase.Po
In file included from ./wctype.h:59,
from wctype.h:59,
from wctype-h.c:4:
/usr/include/wctype.h:64: error: expected declaration specifiers or '...' before 'locale_t'
/usr/include/wctype.h:73: error: expected declaration specifiers or '...' before 'locale_t'
/usr/include/wctype.h:85: error: expected declaration specifiers or '...' before 'locale_t'
/usr/include/wctype.h:86: error: expected declaration specifiers or '...' before 'locale_t'
In file included from wctype.h:59,
from wctype-h.c:4:
./wctype.h:724: error: conflicting types for 'wctype_t'
/usr/opt/freeware/bin/../lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/sys/types.h:123: error: previous declaration of 'wctype_t' was here
./wctype.h:773: error: conflicting types for 'wctrans_t'
/usr/include/wctype.h:52: error: previous declaration of 'wctrans_t' was here
make: The error code from the last command is 1.


Stop.
make: The error code from the last command is 1.


Stop.
make: The error code from the last command is 2.


Stop.
make: The error code from the last command is 1.


Stop.
make: The error code from the last command is 2.


Stop.

Thanks for any Help.
hightowerki
 
Posts: 5
Joined: Wed Feb 21, 2018 3:31 am

Re: Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby bolson » Wed Feb 21, 2018 11:49 am

It looks like you have two copies of wctype.h and types.h header files on your system. Please run the following commands and post the result:

Code: Select all
find / -name wctype.h
find / -name types.h
Brian Olson
Nagios Support Team
---
Nagios Enterprises, LLC
Email: customersupport@nagios.com
Web: https://www.nagios.com/
User avatar
bolson
The Closer
 
Posts: 692
Joined: Tue Jul 11, 2017 10:34 am

Re: Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby hightowerki » Thu Feb 22, 2018 3:23 am

It looks like i have more than one:

find / -name wctype.h
/apps/nrpe/nagios-plugins-release-2.2.1/gl/wctype.h
/tmp/nrpe/nagios-plugins-1.4.15/gl/wctype.h
/usr/include/wctype.h
/usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/c++/tr1/wctype.h

whereis wctype.h
wctype: /usr/include/wctype.h

find / -name types.h
/apps/pluralsw/nrpe/nagios-plugins-release-2.2.1/gl/sys/types.h
/usr/include/rpc/types.h
/usr/include/sys/types.h
/usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/sys/types.h

whereis types.h
types:
hightowerki
 
Posts: 5
Joined: Wed Feb 21, 2018 3:31 am

Re: Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby bolson » Thu Feb 22, 2018 2:12 pm

I would start by removing the partially installed nrpe like this:

Code: Select all
rm -rf /apps/pluralsw/nrpe
rm -rf /apps/nrpe


Then temporarily rename these:

Code: Select all
/usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/c++/tr1/wctype.h
/usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/sys/types.h


And retry the build. Let me know how you make out.
Brian Olson
Nagios Support Team
---
Nagios Enterprises, LLC
Email: customersupport@nagios.com
Web: https://www.nagios.com/
User avatar
bolson
The Closer
 
Posts: 692
Joined: Tue Jul 11, 2017 10:34 am

Re: Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby hightowerki » Fri Feb 23, 2018 3:45 am

I renamed both files:
Code: Select all
mv /usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/c++/tr1/wctype.h /usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/c++/tr1/testwctype.htest
mv /usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/sys/types.h /usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/sys/testtypes.htest

and run in the same Error:
Code: Select all
        depbase=`echo glthread/threadlib.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I..    -D_THREAD_SAFE  -g -O2 -MT glthread/threadlib.o -MD -MP -MF $depbase.Tpo -c -o glthread/threadlib.o glthread/threadlib.c && mv -f $depbase.Tpo $depbase.Po
        depbase=`echo unistd.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I..    -D_THREAD_SAFE  -g -O2 -MT unistd.o -MD -MP -MF $depbase.Tpo -c -o unistd.o unistd.c && mv -f $depbase.Tpo $depbase.Po
        depbase=`echo wctype-h.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`; gcc -DHAVE_CONFIG_H -I. -I..    -D_THREAD_SAFE  -g -O2 -MT wctype-h.o -MD -MP -MF $depbase.Tpo -c -o wctype-h.o wctype-h.c && mv -f $depbase.Tpo $depbase.Po
In file included from ./wctype.h:59,
                 from wctype.h:59,
                 from wctype-h.c:4:
/usr/include/wctype.h:64: error: expected declaration specifiers or '...' before 'locale_t'
/usr/include/wctype.h:73: error: expected declaration specifiers or '...' before 'locale_t'
/usr/include/wctype.h:85: error: expected declaration specifiers or '...' before 'locale_t'
/usr/include/wctype.h:86: error: expected declaration specifiers or '...' before 'locale_t'
In file included from wctype.h:59,
                 from wctype-h.c:4:
./wctype.h:724: error: conflicting types for 'wctype_t'
/usr/include/sys/types.h:102: error: previous declaration of 'wctype_t' was here
./wctype.h:773: error: conflicting types for 'wctrans_t'
/usr/include/wctype.h:52: error: previous declaration of 'wctrans_t' was here
make: The error code from the last command is 1.


Stop.
make: The error code from the last command is 1.


Stop.
make: The error code from the last command is 2.


Stop.
make: The error code from the last command is 1.


Stop.
make: The error code from the last command is 2.


Stop.

Then i tried to rename all files:
Code: Select all
mv /usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/c++/tr1/wctype.h /usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/c++/tr1/testwctype.htest
mv /usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/sys/types.h /usr/opt/freeware/lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/sys/testtypes.htest
mv /usr/include/wctype.h /usr/include/testwctype.htest
mv /usr/include/sys/types.h /usr/include/sys/testtypes.htest
mv /usr/include/rpc/types.h /usr/include/rpc/testtypes.htest

and i run while the compile in a Error:
Code: Select all
configure:4934: checking for C compiler default output file name
configure:4936: result: a.out
configure:4942: checking for suffix of executables
configure:4949: gcc -o conftest    conftest.c  >&5
configure:4953: $? = 0
configure:4975: result:
configure:4997: checking whether we are cross compiling
configure:5005: gcc -o conftest    conftest.c  >&5
In file included from conftest.c:11:
/usr/opt/freeware/bin/../lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/stdio.h:430:23: error: sys/types.h: No such file or directory
In file included from conftest.c:11:
/usr/opt/freeware/bin/../lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/stdio.h:454: error: expected declaration specifiers or '...' before 'off
_t'
/usr/opt/freeware/bin/../lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/stdio.h:455: error: expected '=', ',', ';', 'asm' or '__attribute__' bef
ore 'ftello'
In file included from conftest.c:11:
/usr/opt/freeware/bin/../lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/stdio.h:514: error: expected declaration specifiers or '...' before 'off
64_t'
/usr/opt/freeware/bin/../lib/gcc/powerpc-ibm-aix6.1.0.0/4.2.0/include/stdio.h:516: error: expected '=', ',', ';', 'asm' or '__attribute__' bef
ore 'ftello64'
configure:5009: $? = 1
configure:5016: ./conftest
./configure[5018]: ./conftest:  not found
configure:5020: $? = 127
configure:5027: error: in `/apps/pluralsw/nrpe/nagios-plugins-release-2.2.1':
configure:5029: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

Do you have more Ideas how i get it work?
hightowerki
 
Posts: 5
Joined: Wed Feb 21, 2018 3:31 am

Re: Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby bolson » Fri Feb 23, 2018 4:53 pm

I am continuing to research this. What I have found so far seems to indicate an AIX issue which affects many applications which include these header files in the build process.
Brian Olson
Nagios Support Team
---
Nagios Enterprises, LLC
Email: customersupport@nagios.com
Web: https://www.nagios.com/
User avatar
bolson
The Closer
 
Posts: 692
Joined: Tue Jul 11, 2017 10:34 am

Re: Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby hightowerki » Mon Feb 26, 2018 2:42 am

ok, thank you. I will also search for it.
hightowerki
 
Posts: 5
Joined: Wed Feb 21, 2018 3:31 am

Re: Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby scottwilkerson » Tue Feb 27, 2018 3:28 pm

hightowerki wrote:ok, thank you. I will also search for it.


If you find a solution please share back to this thread so other can benefit.

Thanks!
User avatar
scottwilkerson
CTO
 
Posts: 8921
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby hightowerki » Mon Mar 12, 2018 6:07 am

On other Maschines with the same oslevel i get the same error.
I tried it on a Maschine with newer OS: 7100-04-04-1717

here i could configure it. The make command run into a error.
with gmake it works fine.
hightowerki
 
Posts: 5
Joined: Wed Feb 21, 2018 3:31 am

Re: Configure make nagios-plugins-release-2.2.1 AIX 7.1

Postby scottwilkerson » Tue Mar 13, 2018 9:19 am

Thanks for updating!
User avatar
scottwilkerson
CTO
 
Posts: 8921
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises


Return to Nagios Plugin Development

Who is online

Users browsing this forum: No registered users and 6 guests