Using NRPE to monitor remote linux server -- IP address null

This forum is intended for the discussion of Nagios plugin development. Feature requests, patches, bug fixes, and all types of development-related discussions are welcome!

NOTE: The SourceForge.net nagiosplug-devel mailing list has been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Using NRPE to monitor remote linux server -- IP address null

Postby rogerjbos » Sun Oct 21, 2018 4:00 pm

Fresh install of 4.4.2 with NRPE plugin to monitor a remote linux server which I called orangepione and all 5 checks show orange (unknown) because nagios is timing out after 30 seconds and I am trying to figure out why. Event log shows this:

[10-21-2018 20:55:41] wproc: host=orangepione; service=(null);

I set up NRPE logging and the last few lines of the nrpe.log file show this:

[1540087467] INFO: SSL/TLS initialized. All network traffic will be encrypted.
[1540087467] Starting up daemon
[1540087467] SETUP_WAIT_CONN FOR: IPv4 address: 0.0.0.0 ((null))
[1540087467] Server listening on 0.0.0.0 port 5666.
[1540087467] SETUP_WAIT_CONN FOR: IPv4 address: :: ((null))
[1540087467] Server listening on :: port 5666.
[1540087467] Listening for connections on port 5666
[1540087467] Allowing connections from: 69.123.xxx.xxx

So it is seeing my IP of 69.123.xxx.xxx, why it is saying service (null) and timing out.
rogerjbos
 
Posts: 6
Joined: Sun Oct 21, 2018 3:49 pm

NRPE error host timeout & service(null)

Postby rogerjbos » Sun Oct 21, 2018 6:33 pm

Trying to configure NRPE to monitor a remote linux server, but I keep getting host timeout errors:

netstat -nap | grep 5666 shows

tcp 0 0 0.0.0.0:5666 0.0.0.0:* LISTEN 201/nrpe
tcp6 0 0 :::5666 :::* LISTEN 201/nrpe

So it seems that my allow IP address is not being parsed correct, but the tail of the nrpe.log file shows the correct IP address 69.123.xxx.xxx

[1540087467] Added command[check_zombie_procs]=/usr/local/nagios/libexec/check_procs -w 5 -c 10 -s Z
[1540087467] Added command[check_total_procs]=/usr/local/nagios/libexec/check_procs -w 150 -c 200
[1540087467] INFO: SSL/TLS initialized. All network traffic will be encrypted.
[1540087467] Starting up daemon
[1540087467] SETUP_WAIT_CONN FOR: IPv4 address: 0.0.0.0 ((null))
[1540087467] Server listening on 0.0.0.0 port 5666.
[1540087467] SETUP_WAIT_CONN FOR: IPv4 address: :: ((null))
[1540087467] Server listening on :: port 5666.
[1540087467] Listening for connections on port 5666
[1540087467] Allowing connections from: 69.123.xxx.xxx

Here is the line I am using in nrpe.cfg:

# NOTE: This option is ignored if NRPE is running under either inetd or xinetd
allowed_hosts=127.0.0.1,69.123.122.212

Thank you in advance for any suggestions you may have!
rogerjbos
 
Posts: 6
Joined: Sun Oct 21, 2018 3:49 pm

Re: Using NRPE to monitor remote linux server -- IP address

Postby rogerjbos » Mon Oct 22, 2018 11:22 am

Solved. I made some changes to the configs and got it working. Not sure 100% which change did the trick, but I think since I am using:

dont_blame_nrpe=0

I had to remove the $ARG1$ and $ARG2$ from the define in command.cfg:

define command{
command_name check_nrpe
command_line $USER1$/check_nrpe -H $HOSTADDRESS$
}

Simple is best. Just glad it is working now. Thanks to all.
rogerjbos
 
Posts: 6
Joined: Sun Oct 21, 2018 3:49 pm

Re: Using NRPE to monitor remote linux server -- IP address

Postby scottwilkerson » Mon Oct 22, 2018 1:37 pm

rogerjbos wrote:Solved. I made some changes to the configs and got it working. Not sure 100% which change did the trick, but I think since I am using:

dont_blame_nrpe=0

I had to remove the $ARG1$ and $ARG2$ from the define in command.cfg:

define command{
command_name check_nrpe
command_line $USER1$/check_nrpe -H $HOSTADDRESS$
}

Simple is best. Just glad it is working now. Thanks to all.


glad you got it resolved!

Locking thread
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 12308
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises


Return to Nagios Plugin Development

Who is online

Users browsing this forum: No registered users and 3 guests