Package ncpa-2.4.1.el8.x86_64.rpm is not signed

This support forum board is for support questions relating to Nagios XI, our flagship commercial network monitoring solution.
Locked
deby23456
Posts: 21
Joined: Tue Apr 11, 2023 1:44 pm

Package ncpa-2.4.1.el8.x86_64.rpm is not signed

Post by deby23456 »

Hello.

I'm trying to update ncpa on one of our Red Hat 8 servers (using yum) that is being monitored and getting the following error:

Package ncpa-2.4.1.el8.x86_64.rpm is not signed
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'yum clean packages'.
Error: GPG check FAILED



Do I have to wait for a corrected, signed version of ncpa? Otherwise, is there a way to get past the error and complete the update?rsion of ncpa? Otherwise, is there a way to get past the error and complete the update?


Looks like it just got updated to 2.4.1. Maybe try reinstalling again? Otherwise I'd wait a couple days and try again.


ADDITIONAL INFO:

Now getting the same error on our Nagios production server running on CentOS 7:

Package ncpa-2.4.1.el7.x86_64.rpm is not signed

As suggested, I'll try again in a few days. Since I have Nagios monitoring for yum updates, I may have to temporarily EXCLUDE ncpa in yum.conf.

On our Nagios DR server running CentOS 7, I tried removing ncpa-2.4.0 and then installing ncpa-2.4.1 but had the same error. I restored the original version with 'yum history undo ##'.


We were getting this as well, from yum-cron. However, when we ran the yum update manually, it offered the suggestion to run this command:
yum --enablerepo=nagios-base clean metadata



Once we ran that, the update worked


Today I was able to install the update. However.....

Yesterday, there was something in the error message that suggested I disable FIPS and try again. I did that, it didn't work, and I re-enabled FIPS. So even though I restarted ncpa_listener, when I check the status, I get 'active (exited)'. Here is the full status message:

Code: Select all
● ncpa_listener.service - LSB: This manages the NCPA Listener service
Loaded: loaded (/etc/rc.d/init.d/ncpa_listener; generated)
Active: active (exited) since Wed 2023-03-01 14:44:46 EST; 4min 38s ago
Docs: man:systemd-sysv-generator(8)
Process: 1444 ExecStart=/etc/rc.d/init.d/ncpa_listener start (code=exited, st>
Tasks: 0 (limit: 49455)
Memory: 0B
CGroup: /system.slice/ncpa_listener.service

Mar 01 14:44:43 c210eibscap01.vornadort.com systemd[1]: Starting LSB: This mana>
Mar 01 14:44:44 c210eibscap01.vornadort.com ncpa_listener[1444]: Starting NCPA >
Mar 01 14:44:44 c210eibscap01.vornadort.com ncpa_listener[1470]: Starting NCPA >
Mar 01 14:44:46 c210eibscap01.vornadort.com ncpa_listener[1470]: ips.c(145): Op>
Mar 01 14:44:46 c210eibscap01.vornadort.com ncpa_listener[1444]: ips.c(145): Op>
Mar 01 14:44:46 c210eibscap01.vornadort.com ncpa_listener[1444]: etc/rc.d/init.>
Mar 01 14:44:46 c210eibscap01.vornadort.com systemd[1]: Started LSB: This manag>



If I run:

Code: Select all
/usr/local/ncpa/ncpa_listener --start



I get this:

Code: Select all
fips.c(145): OpenSSL internal error, assertion failed: FATAL FIPS SELFTEST FAILURE
Aborted (core dumped)



How do I fix this?


please close this top -- I'm have the server restored from backup before the incident occurred/

Refer to my post titled "NagiosXI NCPA deployment failing - FIXED" for root cause of this issue.
User avatar
lgute
Posts: 156
Joined: Mon Apr 06, 2020 2:49 pm

Re: Package ncpa-2.4.1.el8.x86_64.rpm is not signed

Post by lgute »

Hi all,

The link for the "FIXED" post is viewtopic.php?t=65569
Please let us know if you have any other questions or concerns.

-Laura
Locked