Nagios only shows disabled ports from Meraki switch

This board serves as an open discussion and support collaboration point for Nagios XI. NOTE: Nagios XI customers should use the Customer Support forum to obtain expedited support.

Nagios only shows disabled ports from Meraki switch

Postby nagiosfan » Wed May 16, 2018 4:35 pm

We have 4 Meraki switches as one stack. I add those switches into Nagios monitoring pool using SNMP and PING. Each switch has 48 ports but Nagios only shows disabled ports on each switch such as 4 ports on first switch and only 2 ports from second switch, etc. Does anyone has this problem and I would like to hear the solution.
Thanks
nagiosfan
 
Posts: 9
Joined: Wed May 16, 2018 4:22 pm

Re: Nagios only shows disabled ports from Meraki switch

Postby scottwilkerson » Thu May 17, 2018 9:25 am

Did you run the Switch/Router Wizard and that's what you see?

Just trying to collect some information as we do not have that equipment to test with.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
CTO
 
Posts: 9157
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Nagios only shows disabled ports from Meraki switch

Postby nagiosfan » Thu May 17, 2018 12:45 pm

Yes I use netwrok switch/router wizard. After filling all information such as IP, SNMP string and port, the wizard pops up few ports on this witch. I check those ports on Meraki dashboard and those ports are disabled. I did with other switches and same thing happened. All ports appeared on Nagios were disabled. The only device worked was firewall. That device I could see all ports appeared. The only problem was on switches.
nagiosfan
 
Posts: 9
Joined: Wed May 16, 2018 4:22 pm

Re: Nagios only shows disabled ports from Meraki switch

Postby scottwilkerson » Thu May 17, 2018 2:37 pm

I'll leave this thread open if someone has experience with Meraki switchs

Maybe there is a setting on the switch to toggle enabling snmp on all ports (which is usually the default behavior on all switches I have used)
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
CTO
 
Posts: 9157
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Nagios only shows disabled ports from Meraki switch

Postby nagiosfan » Thu May 17, 2018 4:09 pm

The problem seems to be on Nagios setting since I have hooked those switches with other monitor systems like spicework, opmanager and all ports from those switches appeared using snmp.
Thanks
nagiosfan
 
Posts: 9
Joined: Wed May 16, 2018 4:22 pm

Re: Nagios only shows disabled ports from Meraki switch

Postby scottwilkerson » Thu May 17, 2018 4:17 pm

can you PM me your system profile along with the name of this switch and I will have a look

Thanks
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
CTO
 
Posts: 9157
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Nagios only shows disabled ports from Meraki switch

Postby nagiosfan » Thu May 17, 2018 9:42 pm

Here it is
Nagios XI - System Info
System:
Nagios XI Version : 5.4.13
nagiossrvr01 3.10.0-862.el7.x86_64 x86_64
CentOS Linux release 7.5.1804 (Core)
Gnome is not installed
Apache Information
PHP Version: 5.4.16
Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36
Server Name: nagiossrvr01.spoton.com
Server Address: 10.0.10.12
Server Port: 80
Date/Time
PHP Timezone: America/Los_Angeles
PHP Time: Thu, 17 May 2018 19:40:05 -0700
System Time: Thu, 17 May 2018 19:40:05 -0700
Nagios XI Data
License ends in:

Days left in Trial: 57

nagios (pid 10053) is running...
NPCD running (pid 1207).
ndo2db (pid 1943) is running...
CPU Load 15: 0.16
Total Hosts: 15
Total Services: 230
Function 'get_base_uri' returns: http://nagiossrvr01.spoton.com/nagiosxi/
Function 'get_base_url' returns: http://nagiossrvr01.spoton.com/nagiosxi/
Function 'get_backend_url(internal_call=false)' returns: http://nagiossrvr01.spoton.com/nagiosxi ... rofile.php
Function 'get_backend_url(internal_call=true)' returns: http://localhost/nagiosxi/backend/
Ping Test localhost
Running:
/bin/ping -c 3 localhost 2>&1
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.052 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.045 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.060 ms

--- localhost ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1999ms
rtt min/avg/max/mdev = 0.045/0.052/0.060/0.008 ms
Test wget To localhost
WGET From URL: http://localhost/nagiosxi/includes/components/ccm/
Running:
/usr/bin/wget http://localhost/nagiosxi/includes/components/ccm/
--2018-05-17 19:40:07-- http://localhost/nagiosxi/includes/components/ccm/
Resolving localhost (localhost)... ::1, 127.0.0.1
Connecting to localhost (localhost)|::1|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://localhost/nagiosxi/login.php?red ... f&noauth=1 [following]
--2018-05-17 19:40:07-- http://localhost/nagiosxi/login.php?red ... f&noauth=1
Reusing existing connection to [localhost]:80.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: '/usr/local/nagiosxi/tmp/ccm_index.tmp'

0K .......... .......... ..... 3.45M=0.007s

2018-05-17 19:40:08 (3.45 MB/s) - '/usr/local/nagiosxi/tmp/ccm_index.tmp' saved [26419]

Network Settings
1: lo: mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

inet 127.0.0.1/8 scope host lo

valid_lft forever preferred_lft forever

inet6 ::1/128 scope host

valid_lft forever preferred_lft forever

2: ens192: mtu 1500 qdisc mq state UP group default qlen 1000

link/ether 00:50:56:9d:3f:55 brd ff:ff:ff:ff:ff:ff

inet 10.0.10.12/24 brd 10.0.10.255 scope global noprefixroute ens192

valid_lft forever preferred_lft forever

inet6 fe80::250:56ff:fe9d:3f55/64 scope link

valid_lft forever preferred_lft forever


default via 10.0.10.1 dev ens192 proto static metric 100

10.0.10.0/24 dev ens192 proto kernel scope link src 10.0.10.12 metric 100

The name of switches having trouble: 10.0.0.5,10.0.0.6,10.0.0.7,10.0.0.9
You can try to figure out problem on 10.0.0.5 If you can solve problem on one switch, the rest should be done.
nagiosfan
 
Posts: 9
Joined: Wed May 16, 2018 4:22 pm

Re: Nagios only shows disabled ports from Meraki switch

Postby scottwilkerson » Fri May 18, 2018 7:54 am

Sorry I wasn't clear, I was looking for the profile.zip
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
CTO
 
Posts: 9157
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Nagios only shows disabled ports from Meraki switch

Postby nagiosfan » Fri May 18, 2018 10:38 am

The one I posted was the content of profile.zip but if you want me to attach that zip file. Below is the one
Attachments
profile.zip
(101.76 KiB) Downloaded 2 times
nagiosfan
 
Posts: 9
Joined: Wed May 16, 2018 4:22 pm

Re: Nagios only shows disabled ports from Meraki switch

Postby scottwilkerson » Fri May 18, 2018 10:55 am

Looking at the mrtg configuration for 10.0.0.5 it looks like all the ports were "administratively DOWN" when the wizard was run, I can even see it on port 1

If you run the following from the CLI you should be able to see that SNMP is reporting these administratively down
Code: Select all
/usr/bin/cfgmaker --show-op-down --noreversedns --zero-speed 100000000 nagiossnmp@10.0.0.5:161::::2
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
CTO
 
Posts: 9157
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Next

Return to Nagios XI

Who is online

Users browsing this forum: No registered users and 19 guests