Service in not visible in CCM

This board serves as an open discussion and support collaboration point for Nagios XI. NOTE: Nagios XI customers should use the Customer Support forum to obtain expedited support.

Service in not visible in CCM

Postby ISSB_MAOST » Fri Jul 26, 2019 12:46 pm

Hi,

currently we are hosting Nagios 5.6.3, we have a user who created a service through CCM, he can see the service status in GUI Dashboards. but he cannot see the service in CCM. as an admin i can see service but the user cannot.

service configuration:
define service {
service_description Application Server
use application_template
hostgroup_name INTEGRATION SERVERS
check_command check_nrpe!WebSphere_service!!!!!!!
initial_state o
max_check_attempts 5
check_interval 5
retry_interval 1
active_checks_enabled 1
passive_checks_enabled 1
check_period 24x7
process_perf_data 1
retain_status_information 1
retain_nonstatus_information 1
notification_interval 10
notification_period 24x7
notification_options w,c,u,r,
notifications_enabled 1
contacts contact
contact_groups unix_team
register 1
}

Is there any thing that i need to check?
ISSB_MAOST
 
Posts: 79
Joined: Wed Oct 17, 2018 12:55 pm

Re: Service in not visible in CCM

Postby benjaminsmith » Fri Jul 26, 2019 4:18 pm

Hello,

You have the option to set CCM privileges for the user account or make this user an admin to allow CCM access. To manage user privallages go to Admin > Manage Users and click on the user to edit their settings.

user-ccm-permissions.png
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
benjaminsmith
 
Posts: 1475
Joined: Wed Aug 22, 2018 4:39 pm
Location: saint paul

Re: Service in not visible in CCM

Postby ISSB_MAOST » Sun Jul 28, 2019 4:46 pm

Hi,

i have the following settings on user, the user is assigned in the contact list but when the user navigates to CCM>services he cannot see the service config . He can see the service status in service status Dashboards.
see the permissions assigned to user.
Attachments
usersettings.PNG
ISSB_MAOST
 
Posts: 79
Joined: Wed Oct 17, 2018 12:55 pm

Re: Service in not visible in CCM

Postby benjaminsmith » Mon Jul 29, 2019 2:00 pm

Hello @ISSB_MAOST,

I tried to re-create this on my system (using 5.6.3), and didn't get the same behavior. Please try the following.

1. Have the user log out of Nagios XI and then log back in and then check the CCM again to see if he can view the service.

2. Next, temporarily assign the user full CCM access. Is he able to view the service in the CCM? What happens when you change the account back to the limited settings as configured?

Thank you.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
benjaminsmith
 
Posts: 1475
Joined: Wed Aug 22, 2018 4:39 pm
Location: saint paul

Re: Service in not visible in CCM

Postby ISSB_MAOST » Mon Jul 29, 2019 3:01 pm

benjaminsmith wrote:Hello @ISSB_MAOST,

I tried to re-create this on my system (using 5.6.3), and did get the same behavior. Please try the following.

1. Have the user log out of Nagios XI and then log back in and then check the CCM again to see if he can view the service.

2. Next, temporarily assign the user full CCM access. Is he able to view the service in the CCM? What happens when you change the account back to the limited settings as configured?

Thank you.


1. user logged out amd logged in but he cannot see the service in CCM.
2. when he was assigned with full CCM access, he can see all the services like an admin. when the user account is changed to limited settings, the user cannot that service when he is assigned with.
Thanks,
ISSB_MAOST
 
Posts: 79
Joined: Wed Oct 17, 2018 12:55 pm

Re: Service in not visible in CCM

Postby benjaminsmith » Tue Jul 30, 2019 11:41 am

Hello @ISSB_MAOST,

Can you send over your latest profile so we can take a closer look at your configurations. Thanks.

To send us your system profile.
Login to the Nagios XI GUI using a web browser.
Click the "Admin" > "System Profile" Menu
Click the "Download Profile" button
Save the profile.zip file and share in a private message and then[b] reply to this post to bring it up in the queue.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
benjaminsmith
 
Posts: 1475
Joined: Wed Aug 22, 2018 4:39 pm
Location: saint paul

Re: Service in not visible in CCM

Postby ISSB_MAOST » Tue Jul 30, 2019 1:38 pm

Profile sent via PM. Thanks.
ISSB_MAOST
 
Posts: 79
Joined: Wed Oct 17, 2018 12:55 pm

Re: Service in not visible in CCM

Postby ssax » Wed Jul 31, 2019 4:22 pm

Please do this exact process (just for testing):

Have the user logout.

Run this tail command and leave it running (as root):

Code: Select all
tail -Fn0 /var/log/httpd/error_log /var/log/httpd/ssl_error_log /usr/local/nagiosxi/var/cmdsubsys.log /usr/local/nagiosxi/var/eventman.log


Apply Configuration.

Wait 10 minutes.

(yes, leave the tail command running)

Now have the user login and check.

Let us know if they see it, let us know their username, and send us the FULL output from the still running tail command so that we can do some investigating.

Thank you!
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
ssax
Dreams In Code
 
Posts: 4241
Joined: Wed Feb 11, 2015 12:54 pm

Re: Service in not visible in CCM

Postby ISSB_MAOST » Tue Aug 06, 2019 1:18 pm

Please see the PM sent to you.

Thanks,


Moderator's Note: The file has been shared with the support team.
ISSB_MAOST
 
Posts: 79
Joined: Wed Oct 17, 2018 12:55 pm

Re: Service in not visible in CCM

Postby scottwilkerson » Wed Aug 07, 2019 1:56 pm

I want to start by saying I'm sorry the initial test of your findings was done incorrectly, and the tester thought you has a host also assigned to the service (not just a hostgroup).

After re-confirming what you found with the lead architect it is expected behavior, and there is not a way to work around it without adding the contact to a host and adding that host directly to the configuration created.

With the "limited" view that was added to the CCM, we have to make some sacrifices because there is no way to add permissions for a contact to a hostgroup or service group, only to the hosts or services.

The only way to allow someone to see these configs after being applied without making them an admin would be to grant the user "Can see all hosts and services" permissions.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 15796
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Next

Return to Nagios XI

Who is online

Users browsing this forum: Google [Bot] and 10 guests