nagios xi installation is failed

This board serves as an open discussion and support collaboration point for Nagios XI. NOTE: Nagios XI customers should use the Customer Support forum to obtain expedited support.

nagios xi installation is failed

Postby pavan27 » Fri Oct 18, 2019 5:58 pm

Hello Expert's,

I am very new to Naigos , tried to install nagios xi on my local machine. installation is failed with below error. kindly help us on it

Code: Select all
Starting httpd: httpd: apr_sockaddr_info_get() failed for katyayani.localdomain
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
(98)Address already in use: make_sock: could not bind to address [::]:443
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]
RESULT=1

===================
INSTALLATION ERROR!
===================
Installation step failed - exiting.
Check for error messages in the install log (install.log).

If you require assistance in resolving the issue, please include install.log
in your communications with Nagios XI technical support.

The script that failed was: './11-sourceguardian'



I do see error " (98)Address already in use: make_sock: could not bind to address [::]:443" already running. vmware is using that httpd port.
Code: Select all
[root@katyayani nagiosxi]# netstat -anp|grep 443
tcp        0      0 0.0.0.0:443                 0.0.0.0:*                   LISTEN      4822/vmware-hostd
tcp        0      0 :::443                      :::*                        LISTEN      4822/vmware-hostd
unix  3      [ ]         STREAM     CONNECTED     128443 9278/gvfs-gphoto2-v
[root@katyayani nagiosxi]#


Also i am looking Uninstall nagios script. i was not able to locate the script.
Kindly help us on this issue
pavan27
 
Posts: 1
Joined: Fri Oct 18, 2019 5:52 pm

Re: nagios xi installation is failed

Postby mbellerue » Mon Oct 21, 2019 11:19 am

If VMWare is using port 443, then Apache won't be able to bind to that port when it starts up. If it can't bind to that port, Apache won't start, and you won't get an interface to Nagios. Is it possible for VMWare to bind to a different port? If you can do this, then you can pick up the installation from where it left off.

As far as an uninstall script, I don't believe we have one. Generally once Nagios is deployed to a server, that server's job is to run Nagios. This is especially true now that we've moved from physical to virtual machines.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
mbellerue
 
Posts: 800
Joined: Fri Jul 12, 2019 11:10 am


Return to Nagios XI

Who is online

Users browsing this forum: Google [Bot] and 8 guests