Upgrading from 3.5.1 to 4.0.0

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Re: Upgrading from 3.5.1 to 4.0.0

Postby mlong » Sat Sep 28, 2013 11:42 am

of course now changes i make in nagiosql no longer take effect from the gui. I have to restart nagios from the command line to get them to take effect.
mlong
 
Posts: 26
Joined: Mon Aug 12, 2013 12:36 pm

Re: Upgrading from 3.5.1 to 4.0.0

Postby abrist » Mon Sep 30, 2013 9:19 am

Nagiosql may have issues with the init script or with core 4 in general. The real init script fix may have to wait until they fix the bug on tracker.
Former Nagios employee
"It is turtles. All. The. Way. Down. . . .and maybe an elephant or two."
VI VI VI - The editor of the Beast!
Come to the Dark Side.
abrist
Red Shirt
 
Posts: 8334
Joined: Thu Nov 15, 2012 1:20 pm

Re: Upgrading from 3.5.1 to 4.0.0

Postby mlong » Mon Sep 30, 2013 6:03 pm

abrist wrote:Nagiosql may have issues with the init script or with core 4 in general. The real init script fix may have to wait until they fix the bug on tracker.


Ive had to productionalize the Nagios server over the weekend, so I was forced to revert to 3.5.1.

Ill have to wait for any updates til our next quarterly maintenance.
mlong
 
Posts: 26
Joined: Mon Aug 12, 2013 12:36 pm

Re: Upgrading from 3.5.1 to 4.0.0

Postby scottwilkerson » Tue Oct 01, 2013 3:34 pm

Thanks for updating, talking to the dev's this week, I believe a few incremental releaser are planned to catch some bugs that emerged in 4.0.0
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 15796
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Upgrading from 3.5.1 to 4.0.0

Postby nigelb » Sat Oct 12, 2013 10:10 am

I replaced the /etc/init.d/nagios file with the init script from mlong's post 27th Sept and it now works fine.

I'm running Debian Wheezey 64 bit.
(fresh install, Nagios is the first app I've installed on the box)

Nige
nigelb
 
Posts: 2
Joined: Sat Oct 12, 2013 10:04 am

Re: Upgrading from 3.5.1 to 4.0.0

Postby abrist » Mon Oct 14, 2013 10:33 am

Great. That script is not perfect, but it is working and will remain as an ugly hack until it gets fixed proper by the core devs.
Former Nagios employee
"It is turtles. All. The. Way. Down. . . .and maybe an elephant or two."
VI VI VI - The editor of the Beast!
Come to the Dark Side.
abrist
Red Shirt
 
Posts: 8334
Joined: Thu Nov 15, 2012 1:20 pm

Re: Upgrading from 3.5.1 to 4.0.0

Postby nigelb » Mon Oct 14, 2013 12:23 pm

If there is a new release for testing, I'm happy to blitz the box, re-install wheezey and try out a new build if that helps.

Cheers

Nige
nigelb
 
Posts: 2
Joined: Sat Oct 12, 2013 10:04 am

Re: Upgrading from 3.5.1 to 4.0.0

Postby abrist » Mon Oct 14, 2013 12:58 pm

A new init script would not require reinstalling. Unfortunately, I do not think a new debian init script has been officially released as of yet.
Former Nagios employee
"It is turtles. All. The. Way. Down. . . .and maybe an elephant or two."
VI VI VI - The editor of the Beast!
Come to the Dark Side.
abrist
Red Shirt
 
Posts: 8334
Joined: Thu Nov 15, 2012 1:20 pm

Re: Upgrading from 3.5.1 to 4.0.0

Postby alfl » Wed Oct 16, 2013 4:38 am

I am upgrading from version 3.5.1 to 4.0.1 on my ubuntu 12.04 box but the problem is still there. I changed the init script as mentioned in this and other posts but i still am unable to get the service running.
After changing the init script it appears that nagios is started up, checked the config etc. but an /etc/init.d/nagios status still gives an error saying nagios is not running and the website itself says the same.

Also an manual start of nagios doesn't give any error but also fails to start.

Status message of website:

Whoops!

Error: Could not read host and service status information!

Any news on this ?
alfl
 
Posts: 3
Joined: Mon Oct 17, 2011 3:04 am

Re: Upgrading from 3.5.1 to 4.0.0

Postby abrist » Wed Oct 16, 2013 10:46 am

Does it work with systemd?
Code: Select all
service nagios restart
service nagios status
Former Nagios employee
"It is turtles. All. The. Way. Down. . . .and maybe an elephant or two."
VI VI VI - The editor of the Beast!
Come to the Dark Side.
abrist
Red Shirt
 
Posts: 8334
Joined: Thu Nov 15, 2012 1:20 pm

PreviousNext

Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 14 guests