We've moved to a new support system!

The Nagios Answer Hub is a place where you can get help with technical questions from our experts. There, you can quickly open tickets and join discussion boards.

Request Nagios Answer Hub access here: https://info.nagios.com/answer-hub-access-new-users

After completing the access form, you will be given access to a portal where new tickets can be created. We will keep the old customer forum sections and ticket system available for current cases to be resolved.

Go to the Answer Hub

[Nagios-devel] CVS compile/install failure

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

[Nagios-devel] CVS compile/install failure

Postby Guest » Fri May 24, 2002 9:50 am

Good day,

I checked out a CVS copy of Nagios this morning and tried to compile in
MySQL support via the .spec file. However, the install fails.

The install terminates with:


Processing files: nagios-devel-1.0b1-1ignus2
Finding Provides: (using /usr/lib/rpm/find-provides)...
Finding Requires: (using /usr/lib/rpm/find-requires)...
File not found: /var/tmp/nagios-buildroot/usr/sbin/nagios
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames)
<= 3.0.4-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1


RPM build errors:




Scrolling a little ways up reveals the following error:


make[1]: Entering directory `/usr/src/redhat/BUILD/nagios-1.0b1/base'
strip nagios
/usr/bin/install -c -m 775 -d /var/tmp/nagios-buildroot/usr/sbin
/usr/bin/install: `/var/tmp/nagios-buildroot/usr/sbin' exists but is not a
directory
make[1]: *** [install] Error 1


I'm guessing that this is a bug related either to the MySQL support or a
recent bug with CVS, as my compile earlier this week (without MySQL support)
worked fine.

Thanks in advance,

============================
Darren Gamble
Planner, Regional Services
Shaw Cablesystems GP
630 - 3rd Avenue SW
Calgary, Alberta, Canada
T2P 4L4
(403) 781-4948






This post was automatically imported from historical nagios-devel mailing list archives
Original poster: Darren.Gamble@sjrb.ca
Guest
 

Return to Community Support

Who is online

Users browsing this forum: Google [Bot] and 14 guests