problem with check_ldap

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

problem with check_ldap

Postby dialsc » Fri Mar 11, 2011 2:42 am

hello,

i've got a problem with the check_ldap plugin. im running nagios on a gentoo server and when i try using the check_ldap plugin it gives me the following error:
Code: Select all
ldap_bind: Protocol error (2)
        additional info: historical protocol version requested, use LDAPv3 instead
Could not bind to the LDAP server


i've figured out that the plugin knows the command line parameter -3 but whether or not is being recognized depends on (i don't know how it's called) some kind of global attribute in the check_ldap.c file. it's called HAVE_LDAP_SET_OPTION.

here's a snipe from the code:
Code: Select all
#ifdef HAVE_LDAP_SET_OPTION
        printf (" %s\n", "-2 [--ver2]");
  printf ("    %s\n", _("use ldap protocol version 2"));
  printf (" %s\n", "-3 [--ver3]");
  printf ("    %s\n", _("use ldap protocol version 3"));
  printf ("    (%s %d)\n", _("default protocol version:"), DEFAULT_PROTOCOL);
#endif


what do i need to do to become this global attribute set during compilation?

thx,
greez,

dialsc
dialsc
 
Posts: 1
Joined: Fri Mar 11, 2011 2:34 am

Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 15 guests