We've moved to a new support system!

The Nagios Answer Hub is a place where you can get help with technical questions from our experts. There, you can quickly open tickets and join discussion boards.

Request Nagios Answer Hub access here: https://info.nagios.com/answer-hub-access-new-users

After completing the access form, you will be given access to a portal where new tickets can be created. We will keep the old customer forum sections and ticket system available for current cases to be resolved.

Go to the Answer Hub

RE: [Nagios-devel] CVS compile/install failure

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

RE: [Nagios-devel] CVS compile/install failure

Postby Guest » Mon May 27, 2002 12:12 pm

Good day,

Sorry for the repost, but it's been a few days, no one has replied, and this
bug persists in CVS.

Some more investigation reveals that it is the aforementioned p1.pl file
that gets installed as the "sbin" file. It looks like somebody recently
made a change to actually install p1.pl in /usr/sbin under the buildroot,
but the result of the change was not actually tested. It appears that the
directory /usr/sbin does not exist at that point, so p1.pl gets installed as
the FILE /usr/sbin.

Please fix this. =)

Thanks in advance,

============================
Darren Gamble
Planner, Regional Services
Shaw Cablesystems GP
630 - 3rd Avenue SW
Calgary, Alberta, Canada
T2P 4L4
(403) 781-4948


> -----Original Message-----
> From: Darren Gamble [mailto:Darren.Gamble@sjrb.ca]
> Sent: Friday, May 24, 2002 11:45 AM
> To: nagios-devel@lists.sourceforge.net
> Subject: [Nagios-devel] CVS compile/install failure
>
>
> Good day,
>
> I checked out a CVS copy of Nagios this morning and tried to
> compile in
> MySQL support via the .spec file. However, the install fails.
>
> The install terminates with:
>
>
> Processing files: nagios-devel-1.0b1-1ignus2
> Finding Provides: (using /usr/lib/rpm/find-provides)...
> Finding Requires: (using /usr/lib/rpm/find-requires)...
> File not found: /var/tmp/nagios-buildroot/usr/sbin/nagios
> PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(CompressedFileNames)
> <= 3.0.4-1
> Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(CompressedFileNames) <= 3.0.4-1
>
>
> RPM build errors:
>
>
>
>
> Scrolling a little ways up reveals the following error:
>
>
> make[1]: Entering directory `/usr/src/redhat/BUILD/nagios-1.0b1/base'
> strip nagios
> /usr/bin/install -c -m 775 -d /var/tmp/nagios-buildroot/usr/sbin
> /usr/bin/install: `/var/tmp/nagios-buildroot/usr/sbin' exists
> but is not a
> directory
> make[1]: *** [install] Error 1
>
>
> I'm guessing that this is a bug related either to the MySQL
> support or a
> recent bug with CVS, as my compile earlier this week (without
> MySQL support)
> worked fine.
>
> Thanks in advance,
>
> ============================
> Darren Gamble
> Planner, Regional Services
> Shaw Cablesystems GP
> 630 - 3rd Avenue SW
> Calgary, Alberta, Canada
> T2P 4L4
> (403) 781-4948
>
>
> _______________________________________________________________
>
> Don't miss the 2002 Sprint PCS Application Developer's Conference
> August 25-28 in Las Vegas -- http://devcon.sprintpcs.com/adp/index.cfm
>
> _______________________________________________
> Nagios-devel mailing list
> Nagios-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/nagios-devel
>





This post was automatically imported from historical nagios-devel mailing list archives
Original poster: Darren.Gamble@sjrb.ca
Guest
 

Return to Community Support

Who is online

Users browsing this forum: No registered users and 16 guests