Web Authentication Problem

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Web Authentication Problem

Postby kashbrok » Tue Jul 05, 2011 12:19 pm

Howdy,

I just want to start this off with a disclaimer: I am completely new to Nagios and rough in linux.

Roughly around the time the last engineer left web authentication broke for our Nagios install. When I as digging around I couldn't find any traces of certain steps of the setup related to authentication ie: .htaccess or *.users files. I made those changes and still haven't had any luck and web authentication is still broken, but alerts are still being sent out via email. Can someone suggest where I should start digging and what I should backup before I really start digging?

Thanks
kashbrok
 
Posts: 1
Joined: Tue Jul 05, 2011 11:43 am

Re: Web Authentication Problem

Postby mguthrie » Fri Jul 08, 2011 12:07 am

Check your apache configs for where the user authorization file is for the /nagios web alias, most installs have this as htpasswd.users by default. You can use the htpasswd command to reset passwords for users if needed.

htpasswd <auth_file> -c <username>

If you need more details go ahead and post a reply.
mguthrie
 
Posts: 4384
Joined: Mon Jun 14, 2010 10:21 am


Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 18 guests