Page 1 of 1

Problems installing Nagios-3.2.3 on ubuntu 10.10

PostPosted: Thu Jul 07, 2011 8:58 am
by tsioutas
Hi there.

I ve installed nagios-3.2.3
I ve installed apache2

I ve checked the status of both

/etc/init.d/nagios status
up and running

/etc/init.d/apache2 status
up and running

But cannot reach the web interface

Any ideas??? please help

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

PostPosted: Thu Jul 07, 2011 9:09 am
by lmiltchev
Disable your firewall (iptables) temporarily to eliminate this possibility and also check your selinux. You can disable it temporarily by running in terminal: "setenforce 0"

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

PostPosted: Thu Jul 07, 2011 9:28 am
by tsioutas
I just did it but nothing. Any other ideas?

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

PostPosted: Thu Jul 07, 2011 12:40 pm
by mguthrie
Did you install from source of using apt? If you're using apt you need to access the page from http://<address>/nagios3. Take a look at your /etc/apache2/conf.d directory and see where the nagios alias is pointing. Verify that it's pointing to the correct directory location for the web front-end.

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

PostPosted: Fri Jul 08, 2011 2:34 am
by tsioutas
/etc/apache2conf.d contains the following files :

charset localised-error-pages other-vhosts-access-log security

which one should I configure?

Re: Problems installing Nagios-3.2.3 on ubuntu 10.10

PostPosted: Fri Jul 08, 2011 9:24 am
by mguthrie
If you installed from apt you should already have a file somewhere called nagios3.conf. Otherwise if you installed from source, one of the last steps in the install process is "make install-webconf" and that will create the apache conf file for you as well. If you don't have either of these, here's the conf file from a source install. Change file and directory locations to match your install. You'll need to use the htpasswd command to add a password protected user to the htpasswd.users file.

Code: Select all
ScriptAlias /nagios/cgi-bin "/usr/local/nagios/sbin"

<Directory "/usr/local/nagios/sbin">
#  SSLRequireSSL
   Options ExecCGI
   AllowOverride None
   Order allow,deny
   Allow from all
#  Order deny,allow
#  Deny from all
#  Allow from 127.0.0.1
   AuthName "Nagios Core"
   AuthType Basic
   AuthUserFile /usr/local/nagiosxi/etc/htpasswd.users
   Require valid-user
</Directory>

Alias /nagios "/usr/local/nagios/share"

<Directory "/usr/local/nagios/share">
#  SSLRequireSSL
   Options None
   AllowOverride None
   Order allow,deny
   Allow from all
#  Order deny,allow
#  Deny from all
#  Allow from 127.0.0.1
   AuthName "Nagios Core"
   AuthType Basic
   AuthUserFile /usr/local/nagiosxi/etc/htpasswd.users
   Require valid-user
</Directory>