Debian Install not working...

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Debian Install not working...

Postby DonGould » Wed Jul 13, 2011 3:08 am

viewtopic.php?f=7&t=2502&p=10702&hilit=debian#p10702

I followed the above instructions, use web browser to open localhost/nagios3, got prompted for user/password --> blank page

user: nagiosadmin
pwd: <one entered in the installation>

I'm new to Nagios, so a pointer to what I should be looking at to get it going?

D
DonGould
 
Posts: 3
Joined: Wed Jul 13, 2011 2:25 am

Re: Debian Install not working...

Postby mguthrie » Wed Jul 13, 2011 9:23 am

You need to add the nagiosadmin user and password to a file called htpasswd.users. I'm not sure where the nagios3 package puts it, but look in the /etc/apache2/conf.d/nagios3.conf file to find where that file is supposed to be. Then use the htpasswd command to add users to it.

Code: Select all
htpasswd -c <htpasswd.users file location> <username>     ##this will prompt you for a password. 
mguthrie
 
Posts: 4384
Joined: Mon Jun 14, 2010 10:21 am

Re: Debian Install not working...

Postby DonGould » Thu Jul 14, 2011 5:56 am

Thanks, that got the menu to come up.

Now when I click on Tactical Overview I get...

Code: Select all
Whoops!

Error: Could not read object configuration data!

Here are some things you should check in order to resolve this error:

    Verify configuration options using the -v command-line option to check for errors.
    Check the Nagios log file for messages relating to startup or status data errors.


I've checked -v and can't see any issues and looked in the log file.

I've also looked at: http://forums.gentoo.org/viewtopic-t-47 ... art-0.html

It occurred to me that I might have a rights problem, but I'm not sure that's it as I've put most stuff in my www-grp now.

I tried looking in the KB but the only issue I could find there didn't seem to apply.

http://support.nagios.com/knowledgebase ... wdesc=true

nagios is running.

Code: Select all
[1310639853] Nagios 3.2.1 starting... (PID=25344)
[1310639853] Local time is Thu Jul 14 22:37:33 NZST 2011
[1310639853] LOG VERSION: 2.0
[1310639853] Finished daemonizing... (New PID=25345)
DonGould
 
Posts: 3
Joined: Wed Jul 13, 2011 2:25 am

Re: Debian Install not working...

Postby mguthrie » Thu Jul 14, 2011 10:06 am

Hmm, not sure, I'd try reviewing the info in the cgi.cfg file and see if there's anything problematic there. I haven't done a Debian install before, but maybe this tutorial could help...

http://unixmen.com/linux-tutorials/1556-install-nagios-in-1-command-on-ubuntu-and-debian-squeez
mguthrie
 
Posts: 4384
Joined: Mon Jun 14, 2010 10:21 am

Re: Debian Install not working...

Postby DonGould » Thu Jul 14, 2011 6:24 pm

mguthrie wrote:Hmm, not sure, I'd try reviewing the info in the cgi.cfg file and see if there's anything problematic there. I haven't done a Debian install before, but maybe this tutorial could help...

http://unixmen.com/linux-tutorials/1556-install-nagios-in-1-command-on-ubuntu-and-debian-squeez


That was the link I followed to install it.

I've looked in cgi.cfg and can't see anything that looks like it would be causing issues.

What is 'object configuration data'?

What's trying to read it?
DonGould
 
Posts: 3
Joined: Wed Jul 13, 2011 2:25 am

Re: Debian Install not working...

Postby mguthrie » Sat Jul 16, 2011 12:13 pm

The object configuration data is the info on all of your hosts, services, contacts, etc. On a source install it's all the files in /usr/local/nagios/etc, but I think with an apt package install it's in /etc/nagios or /etc/nagios3. It's where your nagios.cfg file is. Look for these files, make sure they've been created, and also make sure that they have read permissions.
mguthrie
 
Posts: 4384
Joined: Mon Jun 14, 2010 10:21 am


Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 15 guests