SNMP Zywall MIB VPN get error message!?

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

SNMP Zywall MIB VPN get error message!?

Postby Atrolon » Wed Aug 03, 2011 7:47 am

Hi

I am trying to get the status from the VPN tunnel running on my Zywall 5
MIB files are downloaded here: ftp://ftp.zyxel.dk/ZyWALL_5/mib_file/ZyWALL%205_1.zip
I have loaded the MIB files in to MIB browser to get to OID and test the commands works with my router.
And then copyied in to /usr/share/snmp/mibs/

I then try to run this command:
Code: Select all
# /usr/local/nagios/libexec/check_snmp -H 192.168.1.1 -C public -o .1.3.6.1.4.1.890.1.6.1.3.1.1.16 -m /usr/share/snmp/mibs/zyxel-zywall.mib


And this is what I get:
Code: Select all
External command error: Expected "(" (_): At line 542 in /usr/share/snmp/mibs/zyxel-zywall.mib
Should be ACCESS (TO): At line 542 in /usr/share/snmp/mibs/zyxel-zywall.mib
Bad parse of OBJECT-TYPE: At line 542 in /usr/share/snmp/mibs/zyxel-zywall.mib
Error in packet
Reason: (noSuchName) There is no such variable name in this MIB.
Failed object: ZYXEL-MIB::zywallCommon.3.1.1.16



I opende the MIB file in VI and this is line 542:
Code: Select all
   firewallDirIndex OBJECT-TYPE
      SYNTAX  INTEGER {
line 542 LAN_TO_WAN(1),
         WAN_TO_LAN(2),
         DMZ_TO_LAN(3),
         DMZ_TO_WAN(4),
         WAN_TO_DMZ(5),
         LAN_TO_DMZ(6),
         LAN_TO_LAN(7),
         WAN_TO_WAN(8),
         DMZ_TO_DMZ(9),
         LAN_TO_ROUTER(10),
         WAN_TO_ROUTER(11),
         DMZ_TO_ROUTER(12)
      }
      ACCESS  read-only
      STATUS  mandatory
      DESCRIPTION
         "The index of Firewall direction."
      ::= { firewallDirEntry 1 }



other SMNP commands like this one:
Code: Select all
# /usr/local/nagios/libexec/check_snmp -H 192.168.1.1 -C public -o .1.3.6.1.2.1.1.3.0 -m ALL

Works perfectly

Hope someone have an idear of what is going wrong?

Thanks
Atrolon
 
Posts: 2
Joined: Wed Aug 03, 2011 7:12 am

Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 29 guests