RHEL4 up2date fails header download for nagios-0-2.12-9...

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

RHEL4 up2date fails header download for nagios-0-2.12-9...

Postby libove » Wed Aug 03, 2011 2:22 pm

I'm trying to run 'up2date -u' on an RHEL4 ES (i386/i686, 32-bit) system. It always fails with:

Testing package set / solving RPM inter-dependencies...

Downloading headers to solve dependencies...
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
An error has occurred:
exceptions.UnboundLocalError
See /var/log/up2date for more information


The thing is, when I look in the package lists, that precise version of nagios (nagios-0-2.12-9.el4.i386.hdr) is out-of-date. The version actually in the repositories (I checked several mirrors) is nagios-0-2.12-10.el4.i386.hdr.

I tried clearing the up2date/yum caches - they just rebuilt and came back to the same error.

I'll point out too that nagios isn't even installed on this system:

rpm -qa | grep -i nagios
nagios-plugins-1.4.15-2.el4.rf


.. so I don't think this is an actual dependency, but rather something more general in the RHEL4 up2date repository.


What can I check to see what may be outdated, or otherwise reconcile this mismatch in some dependency as compared to the actual package version available?

This is preventing me from up2date'ing any package at all on the server, even those with no relation whatsoever to nagios.


I realise that this isn't strictly nagios related, but rather RedHat packaging of nagios. I've not been able to find any posts which seem to refer to this, here or on other forums, so I appreciate your indulgence and any help you can offer!

Thanks!
-Jay
libove
 
Posts: 1
Joined: Wed Aug 03, 2011 2:09 pm

Return to Nagios Core

Who is online

Users browsing this forum: MSN [Bot] and 30 guests