Nagios 3.3.1 - Home page - 500 Internal Server Error

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Nagios 3.3.1 - Home page - 500 Internal Server Error

Postby Lee-TIC » Thu Aug 04, 2011 10:54 am

Hello All,

I just upgraded my Nagios 3.2.3 to 3.3.1. After the install however, the home.php page will not display. When loading Nagios I see the side bar and all other pages appear to work except the home.php.

If I donwgrade to 3.2.3 everything works, but as soon as I re-apply 3.3.1, the home.php page breaks.

Has anyone experienced this as well or have any idea what would be causing this?

Thanks in advance!
Lee-TIC
 
Posts: 4
Joined: Thu Aug 04, 2011 10:30 am

Re: Nagios 3.3.1 - Home page - 500 Internal Server Error

Postby agriffin » Thu Aug 04, 2011 12:15 pm

There shouldn't even be a home.php in either version. You probably mean index.php or main.php. It may be caused by the new RSS feeds that are fetched and displayed on that page. In any case, 3.3.1 is a development version and not guaranteed to be stable.
agriffin
 
Posts: 876
Joined: Mon May 09, 2011 9:36 am

Re: Nagios 3.3.1 - Home page - 500 Internal Server Error

Postby Lee-TIC » Thu Aug 04, 2011 2:00 pm

I am sorry. You are correct. I did mean main.php not home. The index.php loads fine as I can see the left side bar. When I access the index.php (or main.php directly) is when I am seeing this issue.

Thanks for your response.
Lee-TIC
 
Posts: 4
Joined: Thu Aug 04, 2011 10:30 am

Re: Nagios 3.3.1 - Home page - 500 Internal Server Error

Postby agriffin » Thu Aug 04, 2011 2:05 pm

I've opened a related bug report here that you may want to keep an eye on.
agriffin
 
Posts: 876
Joined: Mon May 09, 2011 9:36 am

Re: Nagios 3.3.1 - Home page - 500 Internal Server Error

Postby Lee-TIC » Thu Aug 04, 2011 4:53 pm

Thanks I will keep on eye on it.
Lee-TIC
 
Posts: 4
Joined: Thu Aug 04, 2011 10:30 am

Re: Nagios 3.3.1 - Home page - 500 Internal Server Error

Postby Master_Chief_Jon » Mon Aug 08, 2011 6:25 am

I just upgraded from 3.2.3 to 3.3.1 on my Nagios test system, and I had a make error when compiling. In addition, the main.php page would not display. I looked in the apache2 error_log (/var/log/apache2) and found that there were class files missing from the folder <nagios_install_dir>/share/includes/rss/extlib. In addition, the other 2 directories that should have been created under includes/rss were not created. That generated the error I saw in the make install results. I simply manually created the 3 missing directories, and copied the files from the /tmp directory where I extracted them, set the permissions on all of these files to 664 and owner/group to nagios/nagios. A quick nagios service restart and it was working.
P.S., I did not like the Exfoliation UI, so I went back and ran make install-classicui and restarted the nagios service to get back to the old look & feel.
Master_Chief_Jon
 
Posts: 22
Joined: Fri Nov 19, 2010 1:31 pm


Return to Nagios Core

Who is online

Users browsing this forum: charmainequek, MSN [Bot] and 24 guests