Browser doesn't reload

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Browser doesn't reload

Postby becatini » Wed Aug 31, 2011 8:32 am

Hi all.

Nagios page doesn't reload in any browser.
I have tried in IE, firefox and chrome and the system operation is windows 7 32bits.
I need to keep pressing <F5> every time that I need to check for any change.

Can anyone help me on this??
Thanks
Fabiano.
becatini
 
Posts: 1
Joined: Wed Aug 31, 2011 8:22 am

Re: Browser doesn't reload

Postby grittyminder » Wed Aug 31, 2011 6:19 pm

You can set the client browser refresh rate (in seconds) by changing the value of refresh_rate in /usr/local/nagios/etc/cgi.cfg
grittyminder
 
Posts: 2
Joined: Wed Aug 31, 2011 4:06 am

Re: Browser doesn't reload

Postby yaruigon » Fri Sep 02, 2011 4:51 am

Hi,

I have the same problem with becatini here.
My browser did not load properly, but it is work on other programs just fine.

I try to follow the instruction but comes up with no good result.
Please help.
yaruigon
 
Posts: 1
Joined: Fri Sep 02, 2011 4:47 am

Re: Browser doesn't reload

Postby ablowyr3 » Fri Sep 02, 2011 9:50 pm

I am having the same problem as well
ablowyr3
 
Posts: 1
Joined: Fri Sep 02, 2011 9:46 pm

Re: Browser doesn't reload

Postby beaudecor » Tue Sep 06, 2011 6:11 am

Ive also had this problem! Anyone got any ideas?

Much appreciated.
beaudecor
 
Posts: 1
Joined: Tue Sep 06, 2011 6:04 am

Re: Browser doesn't reload

Postby crfriend » Tue Sep 06, 2011 10:20 am

There are a number of things that may be in play here, including the possibility that auto-refreshes may not be enabled on the browser in question. Making sure that the proper option (refresh_rate=90) is set in the cgi.cfg file is a good place to start. Restarting the Nagios instance is not required for changes to cgi.cfg.

Beyond that, one will need to perform a packet trace to get a look at the HTTP response headers from the server where the CGIs run and look for a string like: "Refresh: 90\r\n". If that string is there and the browser isn't refreshing then the browser is misbehaving; if the string is NOT there, then the configuration of the web-server needs to be checked as it's not transmitting the command to perform an auto-refresh.
crfriend
 
Posts: 61
Joined: Thu Sep 01, 2011 7:53 am
Location: Central New England (USA)

Re: Browser doesn't reload

Postby ccooper » Wed Sep 07, 2011 10:31 am

It's working fine to me, browser reload.
ccooper
 
Posts: 1
Joined: Wed Sep 07, 2011 10:26 am

Re: Browser doesn't reload

Postby sparob9 » Mon Sep 12, 2011 12:48 am

I have also been having the same problem. Thanks for the ideas, they worked fine for me. :)
sparob9
 
Posts: 1
Joined: Mon Sep 12, 2011 12:38 am

Re: Browser doesn't reload

Postby calderetaz » Tue Sep 13, 2011 1:59 am

I had the same problem too.
calderetaz
 
Posts: 1
Joined: Tue Sep 13, 2011 1:52 am

Re: Browser doesn't reload

Postby mikevedaya » Tue Sep 13, 2011 11:41 pm

Its working fine for me in all browzers.....
mikevedaya
 
Posts: 1
Joined: Tue Sep 13, 2011 11:33 pm
Location: India

Next

Return to Nagios Core

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 12 guests