Nagios 4 on Raspberry PI 3

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Nagios 4 on Raspberry PI 3

Postby t3dus » Thu May 12, 2016 10:57 pm

So I installed Nagios 4 on my raspberry Pi but after loading into the interface it shows a big red X and says "Not running"

I manually tried to restart nagios and even though it claims it's running the interface states differently.

Code: Select all
root@raspberrypi:~# systemctl status nagios
● nagios.service - Nagios
   Loaded: loaded (/etc/systemd/system/nagios.service; enabled)
   Active: active (running) since Fri 2016-05-13 03:56:25 UTC; 22s ago
Main PID: 804 (nagios)
   CGroup: /system.slice/nagios.service
           ├─804 /usr/local/nagios/bin/nagios /usr/local/nagios/etc/nagios.cf...
           ├─805 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/...
           ├─806 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/...
           ├─807 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/...
           ├─808 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/...
           ├─809 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/...
           ├─810 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/...
           └─811 /usr/local/nagios/bin/nagios /usr/local/nagios/etc/nagios.cf...

May 13 03:56:25 raspberrypi nagios[804]: nerd: Fully initialized and ready t...!
May 13 03:56:25 raspberrypi nagios[804]: wproc: Successfully registered mana...r
May 13 03:56:25 raspberrypi nagios[804]: wproc: Registry request: name=Core ...5
May 13 03:56:25 raspberrypi nagios[804]: wproc: Registry request: name=Core ...8
May 13 03:56:25 raspberrypi nagios[804]: wproc: Registry request: name=Core ...6
May 13 03:56:25 raspberrypi nagios[804]: wproc: Registry request: name=Core ...9
May 13 03:56:25 raspberrypi nagios[804]: wproc: Registry request: name=Core ...7
May 13 03:56:25 raspberrypi nagios[804]: wproc: Registry request: name=Core ...0
May 13 03:56:25 raspberrypi nagios[804]: Successfully launched command file ...1
May 13 03:56:25 raspberrypi nagios[804]: Successfully launched command file ...1
Hint: Some lines were ellipsized, use -l to show in full.


What could be the problem?
User avatar
t3dus
 
Posts: 147
Joined: Thu Feb 04, 2016 3:46 pm
Location: IA

Re: Nagios 4 on Raspberry PI 3

Postby t3dus » Thu May 12, 2016 11:16 pm

Nm. I ran these 2 commands and it fixed the problem.

Code: Select all
# mv /etc/apache2/mods-available/cgi.load /etc/apache2/mods-enabled/
# service apache2 restart
User avatar
t3dus
 
Posts: 147
Joined: Thu Feb 04, 2016 3:46 pm
Location: IA

Re: Nagios 4 on Raspberry PI 3

Postby rhassing » Fri May 13, 2016 5:13 am

Normally you should have created a symbolic link instead of moving the file.
But I assume this works as well.
Rob Hassing
Image
Have I been helpful? Nominate me for a Nagios MVP award!
User avatar
rhassing
 
Posts: 365
Joined: Sat Oct 05, 2013 10:29 pm
Location: Netherlands

Re: Nagios 4 on Raspberry PI 3

Postby mcapra » Fri May 13, 2016 9:20 am

@t3dus,

I'm glad you were able to find a solution! As rhassing pointed out, typically a symlink would be used in favor of moving the file. Is it all right if we lock this topic and mark it as resolved?
Former Nagios employee
http://www.mcapra.com/
User avatar
mcapra
 
Posts: 3587
Joined: Thu May 05, 2016 3:54 pm

Re: Nagios 4 on Raspberry PI 3

Postby t3dus » Tue Apr 18, 2017 8:01 pm

Yes mark it as resolved. Yes you are likely right about the symbolic link but oh well it still works fine.
User avatar
t3dus
 
Posts: 147
Joined: Thu Feb 04, 2016 3:46 pm
Location: IA


Return to Nagios Core

Who is online

Users browsing this forum: Majestic-12 [Bot] and 9 guests