performance data empty

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

performance data empty

Postby sneppie » Wed Dec 14, 2016 8:37 am

Hello,

I want to use Nagios and PNP4Nagios to monitor my local server (Ubuntu 16.04 LTS). It's configured in NPCE Bulk mode and I want to monitor the local host. All performance data is saved in: /usr/local/pnp4nagios/var/perfdata/.pnp-internal/ .

PNP4Nagios still has error message: "perfdata directory "/usr/local/pnp4nagios/var/perfdata/localhost" is empty.". Probably because folder is hidden?

How can I fix this?

Thank you in advance.

Greetz Richard
sneppie
 
Posts: 10
Joined: Wed Dec 14, 2016 1:44 am

Re: performance data empty

Postby dwhitfield » Wed Dec 14, 2016 10:57 am

Is NPCD running? Please post the output of the following:

Code: Select all
service npcd status


If that doesn't fix things, can you post these two files:

Code: Select all
/usr/local/nagios/etc/pnp/process_perfdata.cfg
/usr/local/nagios/etc/nagios.cfg
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3486
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Re: performance data empty

Postby sneppie » Wed Dec 14, 2016 11:47 am

Npcd status is running:

root@homeserver:/home/richard# service npcd status
● npcd.service - LSB: pnp4nagios NPCD Daemon Version 0.6.25
Loaded: loaded (/etc/init.d/npcd; bad; vendor preset: enabled)
Active: active (running) since vr 2016-12-02 21:19:04 CET; 1 weeks 4 days ago
Docs: man:systemd-sysv-generator(8)
CGroup: /system.slice/npcd.service
└─29605 /usr/local/pnp4nagios/bin/npcd -d -f /usr/local/pnp4nagios/etc/npcd.cfg


Requested files are attached. Also added the ncpe log file.

process_perfdata.cfg
(2.44 KiB) Downloaded 21 times

nagios.cfg
(44.29 KiB) Downloaded 20 times

npcd.log
(473.79 KiB) Downloaded 15 times
sneppie
 
Posts: 10
Joined: Wed Dec 14, 2016 1:44 am

Re: performance data empty

Postby dwhitfield » Wed Dec 14, 2016 12:24 pm

What version of Core are you using? Was it compiled from source or installed from distro repos?

Also, PNP4Nagios is not our product, so you might get better results on their mailing list: https://lists.sourceforge.net/lists/lis ... gios-users

Of course, we can keep this open for community involvement here.
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3486
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Re: performance data empty

Postby sneppie » Wed Dec 14, 2016 1:41 pm

Im using Nagios core version 4.2.2.

Put myself on the PNP4Nagios maillist. Do not know where to ask this question, could not find any forum for PNP4Nagios.
sneppie
 
Posts: 10
Joined: Wed Dec 14, 2016 1:44 am

Re: performance data empty

Postby dwhitfield » Wed Dec 14, 2016 2:35 pm

Your nagios.cfg has no enable_performance_data, and it should be set to 1. It seems like PNP4Nagios requires that but does not put it in the file. That is not a setting in our default nagios.cfg.

right above process_performance_data=1 seems like a good spot to me. Can you add that, restart the nagios service, and report back?

If that doesn't work, could you post the output of tail -100 /usr/local/nagios/var/nagios.log? Also could you PM me your /usr/local/nagios/var/objects.cache. That's probably overkill, but I only want it if adding enable_performance_data=1 doesn't fix the issue for you.
Last edited by dwhitfield on Wed Dec 14, 2016 2:48 pm, edited 1 time in total.
Reason: had user tag instead of icode tag
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3486
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Re: performance data empty

Postby sneppie » Thu Dec 15, 2016 11:10 am

Hi,

The parameter
enable_performance_data=1
is not allowed. I activated it but after restart of the nagios, there was an error. After changing it back, nagios log is error free.

Sent you the requested information by pm.
sneppie
 
Posts: 10
Joined: Wed Dec 14, 2016 1:44 am

Re: performance data empty

Postby dwhitfield » Thu Dec 15, 2016 11:48 am

Unfortunately, I did not get the PM.

You said you are using bulk mode. What happens if you change it to sync mode? Again, I have limited experience with PNP, but that seems to fix these issues for some people.

I don't know how enable_performance_data interacts with PNP, but it's certainly odd that the configs say it is required and then the configs don't work with it in there. If the sync mode doesn't "fix" the issue, we'll do more digging on enable_performance_data. Also, just so we know ahead of time, is there a reason you use bulk mode? If sync mode works, will it work as a permanent fix?
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3486
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Re: performance data empty

Postby sneppie » Fri Dec 16, 2016 2:17 am

I will switch back to sync mode. Let you know the results.

I just switched from sync to NPCD bulk mode :) . Also in sync mode no data was collected.
Code: Select all
verify_pnp_config -m sync -c /usr/local/nagios/etc/nagios.cfg -p /usr/local/pnp4nagios/etc
did not show any error. I found another message on a forum which advised to switch to NPCD bulk mode.

In nagios only the parameter
Code: Select all
process_performance_data=1
is described. No mention of parameter
Code: Select all
enable_performance_data=1
.

PS I have compiled PNP it on the host itself
sneppie
 
Posts: 10
Joined: Wed Dec 14, 2016 1:44 am

Re: performance data empty

Postby dwhitfield » Fri Dec 16, 2016 1:03 pm

sneppie wrote:I found another message on a forum which advised to switch to NPCD bulk mode.


Good catch! I saw that too which made me curious if reversing it would work for you.

I never got a PM from you with the objects.cache. If it's too big to PM, please PM me and I will send you my email address.
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3486
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Next

Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 14 guests