Frozen Emails

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Frozen Emails

Postby Agent007 » Tue Feb 14, 2017 8:24 am

Good Day!!

I have a question.

When I try to use sendEmail, it says the Email was sent successfully! but when I run mailq, it says the emails are frozen. i have tried changing emails and email server but no luck. where could the problem lie?
any help would be appreciated. thanks!

BR
R.R
Agent007
 
Posts: 4
Joined: Tue Feb 07, 2017 5:48 am

Re: Frozen Emails

Postby dwhitfield » Tue Feb 14, 2017 10:50 am

"frozen" is exim speak. Is sendmail pointing to exim? Please attach your /etc/exim/exim.conf (it might be in a different location depending on your OS...which are you running?).

Also, please attach your /etc/mail/sendmail.mc

Also, what version of Core are you running? Are you able to send an email outside of Nagios?
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3850
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Re: Frozen Emails

Postby Agent007 » Thu Feb 16, 2017 4:50 am

Thanks for the reply!!

No I cannot send emails, even though it says email was sent successfully, it shows frozen when I run mailq

I found an exim4.conf.template, is that the same as the exim.conf?

I cannot find the sendmail file

I use Nagios Core 3.5.1 with NEMS in a Raspberry Pi.

Attached is the conf file
Attachments
exim.conf.txt
Exim4.conf.template
(97.76 KiB) Downloaded 7 times
Agent007
 
Posts: 4
Joined: Tue Feb 07, 2017 5:48 am

Re: Frozen Emails

Postby rkennedy » Thu Feb 16, 2017 10:48 am

Can you show us the full output from mailq? Generally these are bouncebacks of some sort or invalid emails, so looking into the messages outputted may provide the headers showing us what's happening. Can you also post a couple of the headers for us to review?

This article may help - http://stackoverflow.com/questions/1716 ... out-sender
rkennedy
 
Posts: 6562
Joined: Mon Oct 05, 2015 11:45 am

Re: Frozen Emails

Postby Agent007 » Fri Feb 17, 2017 5:12 am

Thanks for the reply!!

here are the frozen emails:
26h 1.7K 1ceHSH-00071k-Dp <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

25h 1.7K 1ceIHL-0001u9-Ci <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

25h 1.7K 1ceIRa-0001zi-Eo <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

25h 1.7K 1ceIRy-000219-Tv <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

24h 1.7K 1ceIne-0002DK-CP <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

24h 1.7K 1ceInl-0002DW-5e <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

24h 1.7K 1ceIr6-0002HH-Ea <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx


Somehow I received a notification when i used gmail as smtp server, but when I use another smtp server I receive the error below:

if I use /usr/bin/sendEmail i get this error:

Use of uninitialized value in subroutine entry at /usr/share/perl5/IO/Socket/SSL.pm line 562, <GEN0> line 11.
Feb 17 08:49:09 nems sendEmail[20262]: ERROR => TLS setup failed: SSL structure creation failed error:140BA0C3:SSL routines:SSL_new:null ssl ctx


when I use only sendEmail I get this error:

Use of uninitialized value in subroutine entry at /usr/share/perl5/IO/Socket/SSL.pm line 562, <GEN0> line 11.
Feb 17 10:06:57 nems sendEmail[22689]: ERROR => TLS setup failed: SSL structure creation failed error:140BA0C3:SSL routines:SSL_new:null ssl ctx




Best regards,
RR
Agent007
 
Posts: 4
Joined: Tue Feb 07, 2017 5:48 am

Re: Frozen Emails

Postby dwhitfield » Fri Feb 17, 2017 1:31 pm

Agent007 wrote:
Somehow I received a notification when i used gmail as smtp server, but when I use another smtp server I receive the error below:


This suggests you need to speak with the admin of the non-gmail smtp server to get the proper SSL settings. I'm not sure where the best place for this sort of email question is, maybe https://unix.stackexchange.com/ ? I'm not saying we can't help, but strictly speaking this does not appear to be a Nagios issue and thus we're probably just not the best place.

That said, looking at various bug reports related to your error message it's possible you need to update IO::Socket::SSL, but I don't know what OS you are running, so not sure what command to give you to check if it's installed via repo or cpan. You should figure that out to save yourself some pain down the road. If you type in cpan and you get a notice that says it needs to be installed or that it requires configuration, that's a good sign it is installed via repo.

Also, for clarity, NEMS is not something we built. It only recently came to our attention, so we've done no testing with it. The output of cat /etc/*lease should tell us the OS, which will help us help you.
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3850
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Re: Frozen Emails

Postby Agent007 » Mon Feb 20, 2017 3:48 am

Thanks for the response!

yeah I will talk to the admin of the other smtp server and tell him about the SSL problem

the OS is Debian 8 (jessie) that runs in a raspberry pi.

below is the output of the cat /etc/*lease:
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


Thanks again!

Best regards,
RR
Agent007
 
Posts: 4
Joined: Tue Feb 07, 2017 5:48 am

Re: Frozen Emails

Postby dwhitfield » Mon Feb 20, 2017 2:05 pm

Looks like libio-socket-ssl-perl is the package on Debian and the latest version is 2.002-2+deb8u2, but like I said, make sure you stick with either cpan or the apt repo.

To be clear, I don't think there is necessarily something wrong with the stmp server. I think you just don't have the right settings. I could be wrong about that though.
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3850
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Re: Frozen Emails

Postby rkennedy » Mon Feb 20, 2017 11:56 pm

here are the frozen emails:
26h 1.7K 1ceHSH-00071k-Dp <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

25h 1.7K 1ceIHL-0001u9-Ci <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

25h 1.7K 1ceIRa-0001zi-Eo <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

25h 1.7K 1ceIRy-000219-Tv <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

24h 1.7K 1ceIne-0002DK-CP <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

24h 1.7K 1ceInl-0002DW-5e <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx

24h 1.7K 1ceIr6-0002HH-Ea <> *** frozen ***
smtp-gspfalzfeld@xxxxx.xx


What's is the contents of these? Are they bounced emails by chance?
rkennedy
 
Posts: 6562
Joined: Mon Oct 05, 2015 11:45 am

Re: Frozen Emails

Postby dwhitfield » Wed Mar 01, 2017 2:28 pm

@Agent007, are you still experiencing this issue?
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3850
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC


Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 27 guests