Disabling SSL in REALLY old Nagios self compiled setup

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Disabling SSL in REALLY old Nagios self compiled setup

Postby ddolecki108 » Wed Apr 19, 2017 3:25 pm

Hi,

How to disable SSL in a really really old compilation of Nagios? Please hit me with ideas, I will send version number in a follow up post.
I am assuming that nagios was compiled with SSL support, "way back when".

Thank you very very much.
ddolecki108
 
Posts: 14
Joined: Wed Apr 19, 2017 3:21 pm

Re: Disabling SSL in REALLY old Nagios self compiled setup

Postby mcapra » Wed Apr 19, 2017 3:33 pm

You mean to say you want to disable HTTPS? That would be done via the apache configs. If you share all of the apache configs on this machine, we may be able to lend some insights.
Former Nagios employee - https://github.com/mcapra/
User avatar
mcapra
 
Posts: 2579
Joined: Thu May 05, 2016 3:54 pm

Re: Disabling SSL in REALLY old Nagios self compiled setup

Postby ddolecki108 » Wed Apr 19, 2017 3:43 pm

I did not make myself clear. We are using SSL and we tried check_nrpe -n to disable SSL but that did not work.
Some older clients work fine with the ciphers currently being used, however, the check fails on newer clients with stronger ciphers, we would like for this to work on the newer clients without SSL.
ddolecki108
 
Posts: 14
Joined: Wed Apr 19, 2017 3:21 pm

Re: Disabling SSL in REALLY old Nagios self compiled setup

Postby tacolover101 » Wed Apr 19, 2017 4:14 pm

from my understanding, using the plugin with -n should work and be backwards compatible. your client side NRPE configuration could be telling it to use SSL though. take a look at the configuration.

if it's a matter of the actual NRPE binary supporting SSL, then you'll need to recompile without ssl.
User avatar
tacolover101
 
Posts: 148
Joined: Mon Apr 10, 2017 11:55 am

Re: Disabling SSL in REALLY old Nagios self compiled setup

Postby dwhitfield » Wed Apr 19, 2017 4:19 pm

If you give us some errors, we can help you run through https://assets.nagios.com/downloads/nag ... utions.pdf

Also, if you could post the remote nrpe.cfg, that would helpful. Thanks!
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3252
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Re: Disabling SSL in REALLY old Nagios self compiled setup

Postby ddolecki108 » Wed Apr 19, 2017 4:58 pm

I will post command output tomorrow.
It appears that I need to compile nrpe without ssl support, is that possible?
This page does not give any indication of the arguments to the configure command: https://support.nagios.com/kb/article.php?id=515
ddolecki108
 
Posts: 14
Joined: Wed Apr 19, 2017 3:21 pm

Re: Disabling SSL in REALLY old Nagios self compiled setup

Postby tacolover101 » Thu Apr 20, 2017 1:02 am

i believe that nrpe being compiled without the openssl and openssl-devel packages on the system will build it without ssl support. running a -v against it will tell you how it's currently compiled.

if i remember correctly, --with-openssl is the flag to use to compile with support, so perhaps --without-openssl might work?

also, duringthe compile process there is a section of text that pops up with your selected compile options (just output, no way to change at this part)
User avatar
tacolover101
 
Posts: 148
Joined: Mon Apr 10, 2017 11:55 am

Re: Disabling SSL in REALLY old Nagios self compiled setup

Postby ddolecki108 » Thu Apr 20, 2017 8:33 am

I tried compiling nrpe without ssl, but could not:


[nrpe-3.0.1]# ./configure --enable-command-args --without-openssl

<snip>
configure: WARNING: unrecognized options: --without-openssl
ddolecki108
 
Posts: 14
Joined: Wed Apr 19, 2017 3:21 pm

Re: Disabling SSL in REALLY old Nagios self compiled setup

Postby ddolecki108 » Thu Apr 20, 2017 9:45 am

Okay I'm playing around with the -n option, this is my command and the error message, nothing in logs:
/usr/local/nagios/libexec/check_nrpe -n -H server_name -c check_mem
CHECK_NRPE: Error receiving data from daemon.
ddolecki108
 
Posts: 14
Joined: Wed Apr 19, 2017 3:21 pm

Re: Disabling SSL in REALLY old Nagios self compiled setup

Postby ddolecki108 » Thu Apr 20, 2017 9:58 am

[:~]# /usr/local/nagios/libexec/check_nrpe -n -H server_name
CHECK_NRPE: Error receiving data from daemon.
ddolecki108
 
Posts: 14
Joined: Wed Apr 19, 2017 3:21 pm

Next

Return to Nagios Core

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], mcapra, sartecat and 14 guests