Issues configuring thruk

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Issues configuring thruk

Postby anil4u_04 » Wed May 17, 2017 2:36 am

Hi Team,

We have two nagios instances running in two different servers one is 3.2.0 and other one is 4.0.2 , so we planning to use thruk to have single dashboard . But facing some challenges to achieve this.

Installed thruk successfully, but the challenges are

Installed mk-livestatus-1.2.6p16 (tried with lower version mk-livestatus-1.2.0p4 for the nagios running with 3.2.0) , and livestatus-master in the both the nagios server , added "broker_module=/usr/local/lib/mk-livestatus/livestatus.o /usr/local/nagios/var/rw/live" and also "enable_environment_macros=0"

1) Nagios running with 3.2.0 : upon after restarting the nagios server r, getting the below error

" Error: Could not load module '/usr/local/lib/mk-livestatus/livestatus.o' -> /usr/local/nagios/var/spool/checkresults/nebmodZP1TQg: undefined symbol: num_objects"

i tried moving the files /usr/local/nagios/var/spool/checkresults/nebmod* , but still those are getting create when the restart happens. and the "/usr/local/nagios/var/rw/live" this file is not getting create. Not sure what to do for get the livestatus UP and running.

2) Nagios running with 4.0.2 : here the livestatus is loaded, so added this server in thruk, but when i am clicking the "Hosts" and "Services" tab in the Current Status in Thruk, i am getting the error like below. But "Host Groups" and "Service Groups" are showing the host details in the thruk UI.

UI : saying "No Backend available" and the Details "name: ERROR: The request contains an invalid header. (nagios server IP:6557)"

thruk.log :

[2017/05/17 00:29:33][hostname][ERROR][Thruk] Error in: /thruk/cgi-bin/status.cgi
[2017/05/17 00:29:33][hostname][ERROR][Thruk] The request contains an invalid header. at /usr/share/thruk/lib/Monitoring/Livestatus/Class/Lite.pm line 378
at /usr/lib64/thruk/perl5/Plack/Util.pm line 142
eval {...} called at /usr/lib64/thruk/perl5/Plack/Util.pm line 142
Plack::Util::run_app('CODE(0x2f7b1b8)', 'HASH(0x4ca6470)') called at /usr/lib64/thruk/perl5/Plack/Handler/FCGI.pm line 143
Plack::Handler::FCGI::run('Plack::Handler::FCGI=HASH(0x255dd48)', 'CODE(0x2f7b1b8)') called at /usr/share/thruk/script/thruk_fastcgi.pl line 24
[2017/05/17 00:29:33][hostname][ERROR][Thruk] No Backend available
[2017/05/17 00:29:33][hostname][ERROR][Thruk] on page: http://hostname/thruk/cgi-bin/status.cg ... hostdetail
[2017/05/17 00:29:33][hostname][ERROR][Thruk] SV2: ERROR: The request contains an invalid header. (nagios server IP:6557)

and in livestatus.log

2017-05-17 00:32:29 error: Table 'hosts' has no column 'obsess_over_host'
2017-05-17 00:32:32 error: Table 'services' has no column 'obsess_over_service'

Can someone please help , what was the issue here and what could be the solutions for this.

Your help is much appreciated
anil4u_04
 
Posts: 16
Joined: Tue Sep 24, 2013 5:28 am

Re: Issues configuring thruk

Postby tmcdonald » Wed May 17, 2017 9:16 am

You'll need to reach out to the Thruck and/or Livestatus authors as neither of those were written or are maintained/supported by Nagios.
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tmcdonald
Support Manager
 
Posts: 8262
Joined: Mon Sep 23, 2013 8:40 am

Re: Issues configuring thruk

Postby anil4u_04 » Fri May 19, 2017 3:38 am

Hi tmcdonals,

thanks for the reply, yeah thats true, we need to reach Thruk and livestatus for that. But as a hope, if someone had the same issue and rectified since it is something related to Nagios jut posted it.
anil4u_04
 
Posts: 16
Joined: Tue Sep 24, 2013 5:28 am

Re: Issues configuring thruk

Postby dwhitfield » Fri May 19, 2017 11:37 am

You could just use distributed monitoring instead of thruk: https://assets.nagios.com/downloads/gen ... utions.pdf

There are some references to XI in that document, but you could also do it with a complete Core setup.
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 2819
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC

Re: Issues configuring thruk

Postby anil4u_04 » Tue May 23, 2017 1:04 am

Hi dwhitfield,

Thanks for the suggestion, appreciate it. Will check and revert. Thanks again.
anil4u_04
 
Posts: 16
Joined: Tue Sep 24, 2013 5:28 am

Re: Issues configuring thruk

Postby dwhitfield » Tue May 23, 2017 8:02 am

Let us know if you have any questions!
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 2819
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC


Return to Nagios Core

Who is online

Users browsing this forum: avandemore, monitoring_dude, theO1985 and 13 guests