Nagios with apache 2.4.23

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Nagios with apache 2.4.23

Postby matisse » Wed Jun 14, 2017 10:29 am

Hello, i need you help.
I have Centos 7 and using apache 2.4.23 which i сompiled from sources. If i do yum install httpd than i have too old version 2.4.10, but i need version > 2.4.10 for some reason. I used this documentation for install - https://assets.nagios.com/downloads/nag ... entos7.pdf.
And with apache 2.4.23 i got error 404. But if i remove version 2.4.23 and install again with documentation + yum install htttpd . Than i haven't got problem.
What the problem?
Thanks!
matisse
 
Posts: 22
Joined: Wed Aug 31, 2016 4:33 pm

Re: Nagios with apache 2.4.23

Postby mcapra » Wed Jun 14, 2017 11:38 am

But if i remove version 2.4.23 and install again with documentation + yum install htttpd . Than i haven't got problem


There is a difference between building a shed by hand, and buying a kit from the hardware store. Think of yum as being like a hardware store; They sell pre-built, manufactured stuff (like the httpd package) as well as raw materials to build whatever you like (like the gcc package).

That documentation was written against whatever version of Apache is distributed via the yum package httpd. If that's not the version of Apache you want to use, you'll have to figure out how to change the Apache configurations that Nagios Core automatically creates.

Typically, the make install-webconf step is what creates those Apache configurations. It may be that Nagios Core is attempting to place the Apache configurations in the incorrect path. If you could share the contents of your Apache configuration paths, as well as the contents of those configuration files, that'd be a good start.
Former Nagios employee - https://github.com/mcapra/
User avatar
mcapra
 
Posts: 2457
Joined: Thu May 05, 2016 3:54 pm

Re: Nagios with apache 2.4.23

Postby dwhitfield » Thu Jun 15, 2017 12:11 pm

You might also try https://support.nagios.com/kb/article.php?id=96#CentOS, which are more current. Notice the difference in the Nagios Core version #.
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3061
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC


Return to Nagios Core

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 7 guests