nrpe check_disk have wrong result on nagios web.

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

nrpe check_disk have wrong result on nagios web.

Postby nuryadisan » Thu Jul 13, 2017 11:38 pm

Hi all, I need help. I had problem with my nagios core monitoring. I already check on my nagios server and nagios client. All conf is alright i think. My problem is when I test disk manually from console using command
/usr/lib64/nagios/plugins/check_disk -w 20% -c 10% -p /dev/xvda1
the result is fine. But when i check on my nagios web the result is wrong at disk partition. All my server is 95,44% Please check my attachment for pict.

This my distro information

CentOS Linux release 7.3.1611 (Core)
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"
CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"
CentOS Linux release 7.3.1611 (Core)
CentOS Linux release 7.3.1611 (Core)

I using nagios core 4.3.2
NRPE 2.15


If anything you need to know please let me know.

Cheers!
Attachments
nagios20.png
nuryadisan
 
Posts: 1
Joined: Thu Jul 13, 2017 11:10 pm

Re: nrpe check_disk have wrong result on nagios web.

Postby mcapra » Fri Jul 14, 2017 12:10 pm

Can you share the nrpe.cfg from one of the remote machines, as well as the Nagios service definition you are currently using to check the disks on the same host you are pulling nrpe.cfg from?
Former Nagios employee - https://github.com/mcapra/
User avatar
mcapra
 
Posts: 2561
Joined: Thu May 05, 2016 3:54 pm

Re: nrpe check_disk have wrong result on nagios web.

Postby dwhitfield » Fri Jul 14, 2017 12:24 pm

nuryadisan wrote:
/usr/lib64/nagios/plugins/check_disk -w 20% -c 10% -p /dev/xvda1



This looks like you are running it on the remote machine. What happens when you run the check from the command line on the Nagios server?
Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
dwhitfield
The Doctor
 
Posts: 3239
Joined: Wed Sep 21, 2016 10:29 am
Location: Nagios Enterprises, LLC


Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 18 guests