Problems installing/testing Nagios on OSX Sierra

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Re: Problems installing/testing Nagios on OSX Sierra

Postby scottwilkerson » Wed Sep 06, 2017 12:07 pm

run the following and let us know the results:
Code: Select all
sudo su nagios -c "touch /usr/local/nagios/var/nagios.configtest"
User avatar
scottwilkerson
CTO
 
Posts: 7620
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Problems installing/testing Nagios on OSX Sierra

Postby Aelonia » Tue Sep 12, 2017 3:36 pm

Ran just fine - no output.
Aelonia
 
Posts: 12
Joined: Wed Aug 23, 2017 3:43 pm

Re: Problems installing/testing Nagios on OSX Sierra

Postby scottwilkerson » Tue Sep 12, 2017 3:53 pm

scottwilkerson wrote:Lets do a quick test, edit /etc/rc.d/init.d/nagios

and change this line
Code: Select all
checkconfig="true"

to
Code: Select all
checkconfig="false"


Now lets try to start the service, I just want to make 100% sure the only problem is the configtest file


We've determined there is a bug in 4.3.4 relating to this on some systems and are working to isolate it and fix it in a future release. For now the only option will be to use the above workaround.
User avatar
scottwilkerson
CTO
 
Posts: 7620
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Previous

Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 8 guests