Archived service stats not showing on nagios web

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Archived service stats not showing on nagios web

Postby deepak06live » Wed Sep 13, 2017 3:05 am

I have nagios core software installed to monitor the servers. It's showing real time stats properly but when I am checking previous stats like 1 month old it does not show any data.

Is there any particular configuration so that I can check previous stats also.
deepak06live
 
Posts: 2
Joined: Wed Sep 13, 2017 2:55 am

Re: Archived service stats not showing on nagios web

Postby scottwilkerson » Wed Sep 13, 2017 2:44 pm

Are you deleting your nagios.*.log file from the archives directory? In a source install these are usually located in /usr/local/nagios/var/archives/
Code: Select all
ls -l /usr/local/nagios/var/archives/


This is what is read to get historical stats for availability etc.
User avatar
scottwilkerson
CTO
 
Posts: 7536
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: Archived service stats not showing on nagios web

Postby deepak06live » Fri Sep 15, 2017 2:51 am

Thanks for your reply.
Archive files are properly placed and no file deletion is there. It was due to the permission issue on another file .
After updating permission issue resolved.
deepak06live
 
Posts: 2
Joined: Wed Sep 13, 2017 2:55 am


Return to Nagios Core

Who is online

Users browsing this forum: ishanloki and 21 guests