CHECK_NRPE Socket timeout after n seconds

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

CHECK_NRPE Socket timeout after n seconds

Postby tnr » Wed Jun 13, 2018 12:03 pm

I have a nagios server on centos 7 and I am trying to monitor a remote windows host that has NSClient ++ installed.
I am able to use check_nt from the nagios server but when I use check_nrpe I get "CHECK_NRPE STATE CRITICAL: Socket timeout after 10 seconds."
Below is the output for few commands from the nagios server.

./check_nt -H <ipaddress of remote host> -p 12489 -v CLIENTVERSION
NSClient++ 0.4.4.23 2016-04-05

./check_nrpe -H <ipaddress of remote host>
CHECK_NRPE STATE CRITICAL: Socket timeout after 10 seconds.

(I also tried passing a higher timeout and still the same kind of error)

But if I run the check_nrpe with -V I get the below:
./check_nrpe -H <ipaddress of remote host> -V
NRPE Plugin for Nagios
Copyright (c) 1999-2008 Ethan Galstad (nagios@nagios.org)
Version: 3.1.1
Last Modified: 2017-05-24
License: GPL v2 with exemptions (-l for more info)
SSL/TLS Available: OpenSSL 0.9.6 or higher required

I get the "CHECK_NRPE STATE CRITICAL: Socket timeout after 10 seconds." passing any command using the -c for check_nrpe. Can someone please help me with this issue so that I can monitor the remote window host using check_nrpe for some external scripts?

(Note: I am able to use check_nrpe from the nagios server to other remote linux hosts. I have issue only with windows hosts.The NRPEServer module is enabled on the remote windows host)
tnr
 
Posts: 1
Joined: Wed Jun 13, 2018 10:17 am

Re: CHECK_NRPE Socket timeout after n seconds

Postby scottwilkerson » Wed Jun 13, 2018 4:28 pm

Did you enable NRPE in the nsclient .ini config file?

If so, did you also allow port 5666 through the Windows firewall?

Can you attach that file?
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
CTO
 
Posts: 9799
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises


Return to Nagios Core

Who is online

Users browsing this forum: Fess [Nagios Bot] and 13 guests