Forbidden - You don't have permissions to access /nagios/ on

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Forbidden - You don't have permissions to access /nagios/ on

Postby jimt805 » Fri Aug 10, 2018 2:05 pm

I am a Linux newbie, but I downloaded a fresh install and followed the directions exactly. In looking at previous post, I tailed the last 5 lines of the httpd.error.log file and see the following: Cannot server directory /usr/local/nagios//share/: no matching directoryIndex (index.html) found, and server-generated directory index forbidden by Options directive.

Can someone lead me in the right direction....

Jim
jimt805
 
Posts: 6
Joined: Fri Aug 10, 2018 1:54 pm

Re: Forbidden - You don't have permissions to access /nagios

Postby lmiltchev » Fri Aug 10, 2018 2:23 pm

What directions did you follow? Can you provide us with a URL to the document/guide/tutorial that you used? Can you log in to the web UI at all? What is the OS/architecture of the machine that you tried to install Nagios Core on?
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
lmiltchev
QA Manager
 
Posts: 11239
Joined: Mon May 23, 2011 12:15 pm

Re: Forbidden - You don't have permissions to access /nagios

Postby jimt805 » Fri Aug 10, 2018 2:48 pm

Thank you for your quick response!

Here is the instructions I used. The OS is Centos 7

https://assets.nagios.com/downloads/nag ... 1533651650

I am unable to login to the UI at all. I have tried localhost/nagios from the local machine and ip/nagios from another system, but prompt me for credentials, which a supply: username: nagiosadmin password: ****** and then I get the error.
jimt805
 
Posts: 6
Joined: Fri Aug 10, 2018 1:54 pm

Re: Forbidden - You don't have permissions to access /nagios

Postby npolovenko » Fri Aug 10, 2018 3:47 pm

@jimt805, Make sure you installed all the required packages:
Code: Select all
yum install httpd php php-cli gcc glibc glibc-common gd gd-devel net-snmp openssl-devel wget unzip
-y

And make sure that the firewall is disabled:
Code: Select all
firewall-cmd --zone=public --add-port=80/tcp --permanent
firewall-cmd --reload


If your server is a VM and you can wipe it clean, try to start all over but follow this tutorial instead:
https://support.nagios.com/kb/article/nagios-core-installing-nagios-core-from-source-96.html
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2496
Joined: Mon May 15, 2017 5:00 pm

Re: Forbidden - You don't have permissions to access /nagios

Postby jimt805 » Mon Aug 13, 2018 2:22 pm

Thanks npolovenko,

I went ahead and wiped out the install and started over via your suggestion and it works find now.
jimt805
 
Posts: 6
Joined: Fri Aug 10, 2018 1:54 pm

Re: Forbidden - You don't have permissions to access /nagios

Postby npolovenko » Mon Aug 13, 2018 3:25 pm

@jimt805, You're welcome ;) I'll be closing this thread as resolved.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2496
Joined: Mon May 15, 2017 5:00 pm


Return to Nagios Core

Who is online

Users browsing this forum: benjaminsmith and 22 guests