CHECK_NRPE: Error

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

Re: CHECK_NRPE: Error

Postby npolovenko » Fri Nov 09, 2018 12:27 pm

@BrunoLosse1, Lets try the following. Remove the following line from the ini file that I gave you and restart the nsclient service.
allowed ciphers = ALL:!MD5:@STRENGTH

Then run this again:
cd /usr/local/nagios/libexec
./check_nrpe -H <host ip adddress>
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2492
Joined: Mon May 15, 2017 5:00 pm

Re: CHECK_NRPE: Error

Postby BrunoLosse1 » Fri Nov 09, 2018 12:54 pm

Same error.
Is there any other file I need to edit? Either at the Nagios server or Windows?
BrunoLosse1
 
Posts: 38
Joined: Tue Oct 23, 2018 1:22 pm

Re: CHECK_NRPE: Error

Postby npolovenko » Fri Nov 09, 2018 1:07 pm

@BrunoLosse1, Possibly. Please run the following command(forcing v2 packets) from the nagios XI server:

./check_nrpe -2 -H <nrpe host ip adddress>

And also this one:
./check_nrpe -n -H <nrpe host ip adddress>
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2492
Joined: Mon May 15, 2017 5:00 pm

Re: CHECK_NRPE: Error

Postby BrunoLosse1 » Mon Nov 12, 2018 6:21 am

npolovenko wrote:@BrunoLosse1, Possibly. Please run the following command(forcing v2 packets) from the nagios XI server:

./check_nrpe -2 -H <nrpe host ip adddress>

And also this one:
./check_nrpe -n -H <nrpe host ip adddress>

Here's the results:

administrator@GEUL3BNAGPAS01:/usr/local/nagios/libexec$ ./check_nrpe -2 -H 10.63.248.105
CHECK_NRPE: (ssl_err != 5) Error - Could not complete SSL handshake with 10.63.248.105: 1

administrator@GEUL3BNAGPAS01:/usr/local/nagios/libexec$ ./check_nrpe -n -H 10.63.248.105
CHECK_NRPE: Receive header underflow - only 0 bytes received (4 expected).
BrunoLosse1
 
Posts: 38
Joined: Tue Oct 23, 2018 1:22 pm

Re: CHECK_NRPE: Error

Postby npolovenko » Mon Nov 12, 2018 12:27 pm

@BrunoLosse1, Are IP addresses NATed on your network? Please upload the most recent nsclient.log file from the windows server.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2492
Joined: Mon May 15, 2017 5:00 pm

Re: CHECK_NRPE: Error

Postby BrunoLosse1 » Tue Nov 13, 2018 6:16 am

npolovenko wrote:@BrunoLosse1, Are IP addresses NATed on your network? Please upload the most recent nsclient.log file from the windows server.


No, we don't use NAT.
Attachments
nsclient.log
Here's the log
(1.56 MiB) Downloaded 25 times
BrunoLosse1
 
Posts: 38
Joined: Tue Oct 23, 2018 1:22 pm

Re: CHECK_NRPE: Error

Postby npolovenko » Tue Nov 13, 2018 2:11 pm

@BrunoLosse1, I can see a different kind of error in the log this time. Please change:
cache allowed hosts = 1

to
cache allowed hosts = 0

Then restart the nslcient and let me know if the problem goes away.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2492
Joined: Mon May 15, 2017 5:00 pm

Re: CHECK_NRPE: Error

Postby BrunoLosse1 » Tue Nov 13, 2018 2:18 pm

@npolovenko, got the same error.
Attachments
nsclient.log
(219.28 KiB) Downloaded 29 times
BrunoLosse1
 
Posts: 38
Joined: Tue Oct 23, 2018 1:22 pm

Re: CHECK_NRPE: Error

Postby BrunoLosse1 » Tue Nov 13, 2018 3:02 pm

I found this article https://forums.nsclient.org/t/nagios-ch ... te/4218/15 do you think it might help me? I was following the steps here https://support.nagios.com/kb/article.php?id=519, but got an error.
BrunoLosse1
 
Posts: 38
Joined: Tue Oct 23, 2018 1:22 pm

Re: CHECK_NRPE: Error

Postby npolovenko » Tue Nov 13, 2018 4:12 pm

@BrunoLosse1, You don't need to use custom SSL serts, for now.

In the [/settings/NRPE/server] section of the ini file please add the following line:
ssl options =

And delete this line:
allowed ciphers = ALL:!MD5:@STRENGTH

Then restart the NSClient service.

Run these commands from the Nagios server:
cd /usr/local/nagios/libexec
./check_nrpe -H <host ip adddress>
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
npolovenko
Support Tech
 
Posts: 2492
Joined: Mon May 15, 2017 5:00 pm

PreviousNext

Return to Nagios Core

Who is online

Users browsing this forum: Fess [Nagios Bot], RIDS_I2MP and 26 guests