Page 2 of 3

Re: error general time-out (alarm signal)

PostPosted: Wed Jan 09, 2019 3:56 pm
by shamrozkadiwal
I changed the t value to 60 in the command.cfg file and also change the value of service_chceck_timeout=60 but having same error

Re: error general time-out (alarm signal)

PostPosted: Wed Jan 09, 2019 5:11 pm
by tgriep
Are you getting the "Invalid timeout value" error or the "Invalid timeout value" error?

Re: error general time-out (alarm signal)

PostPosted: Thu Jan 10, 2019 10:00 am
by shamrozkadiwal
getting "error general time-out (alarm signal)"

Re: error general time-out (alarm signal)

PostPosted: Thu Jan 10, 2019 10:11 am
by shamrozkadiwal
I am not sure where do I need to specify the SNMP version for the check_snmp plugin's command line and what version should I put it.
Code: Select all
[root@ams900 ~]# nmap 10.180.50.100 -p 161 -sU

Starting Nmap 7.01 ( https://nmap.org ) at 2019-01-09 09:01 CST
Nmap scan report for asftp900.enclave.local (10.180.50.100)
Host is up (0.00035s latency).
PORT    STATE  SERVICE
161/udp open snmp

Nmap done: 1 IP address (1 host up) scanned in 0.15 seconds
[root@ams900 ~]#


This is the 10.180.50.100 server
Code: Select all
[root@aus50ltasftp900 ~]# snmpd -v

NET-SNMP version:  5.7.2
Web:               http://www.net-snmp.org/
Email:             net-snmp-coders@lists.sourceforge.net

[root@aus50ltasftp900 ~]#

Re: error general time-out (alarm signal)

PostPosted: Thu Jan 10, 2019 4:05 pm
by tgriep
The default snmpd.conf config file needs to be edited to allow certain OID's to be polled so it has to be changed to allow that.
I attached a copy of the file with pretty much all of the settings you may need so on the remote server, replace the /etc/snmp/snmpd.conf file with the attached copy.
Restart the snmpd daemon and test the command again.

Re: error general time-out (alarm signal)

PostPosted: Wed Jan 16, 2019 10:15 am
by shamrozkadiwal
I replaced the snmpd.conf file with your file and still seeing the same error

Re: error general time-out (alarm signal)

PostPosted: Wed Jan 16, 2019 4:03 pm
by tgriep
Sorry, I forgot to mention this, the file I posted you have to use public as the community string and it is also setup to only use SNMP version 2 so you will have to add a -2 to the command and change the community string.
Try this example
Code: Select all
./check_snmp_storage.pl -H 10.180.50.100 -C public -t 60 -m / -r -q FixedDisk -w90 -c95 -G -2

Re: error general time-out (alarm signal)

PostPosted: Thu Jan 17, 2019 11:14 am
by shamrozkadiwal
@tgriep, I tried the command that you gave me and it works like charm :)
Code: Select all
[root@ams900 plugins]# ./check_snmp_storage.pl -H 10.180.50.100 -C public -t 60 -m / -r -q FixedDisk -w90 -c95 -G -2
/: 10%used(2GB/18GB) (<90%) : OK


I was wondering can't I keep nag9899 instead of public.
Code: Select all
[root@ams900 plugins]# ./check_snmp_storage.pl -H 10.180.50.100 -C nag9899 -t 60 -m / -r -q FixedDisk -w90 -c95 -G -2
ERROR: General time-out (Alarm signal)

Re: error general time-out (alarm signal)

PostPosted: Thu Jan 17, 2019 3:07 pm
by tgriep
Edit the snmpd.conf file and change these lines from
Code: Select all
com2sec notConfigUser  default       public
rocommunity public

to
Code: Select all
com2sec notConfigUser  default       nag9899
rocommunity nag9899


Save the file and restart the snmpd daemon so the changes take affect.

Re: error general time-out (alarm signal)

PostPosted: Fri Jan 18, 2019 9:49 am
by shamrozkadiwal
Awesome! Everything looks good now. Thanks for help