nrpe installation error(configure: error)

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

nrpe installation error(configure: error)

Postby sandeep027 » Wed Jun 26, 2019 5:42 am

Hi All,

When i am trying to install nrep, i am getting below error..Please help on this.

Error : checking for SSL headers... configure: error: Cannot find ssl headers

post that i tired the below command , but still getting same error.

./configure --enable-ssl

post that i tried to install this yum command - yum install openssl-devel -y but getting below errors

Error downloading packages:
libsepol-devel-2.5-8.1.el7.x86_64: [Errno 256] No more mirrors to try.
libselinux-devel-2.5-12.el7.x86_64: [Errno 256] No more mirrors to try.
krb5-devel-1.15.1-18.el7.x86_64: [Errno 256] No more mirrors to try.
1:openssl-devel-1.0.2k-12.el7.x86_64: [Errno 256] No more mirrors to try.
zlib-devel-1.2.7-17.el7.x86_64: [Errno 256] No more mirrors to try.
libverto-devel-0.2.5-4.el7.x86_64: [Errno 256] No more mirrors to try.
keyutils-libs-devel-1.5.8-3.el7.x86_64: [Errno 256] No more mirrors to try.
libcom_err-devel-1.42.9-11.el7.x86_64: [Errno 256] No more mirrors to try.
libkadm5-1.15.1-18.el7.x86_64: [Errno 256] No more mirrors to try.
pcre-devel-8.32-17.el7.x86_64: [Errno 256] No more mirrors to try


Can any one please help on this.
sandeep027
 
Posts: 31
Joined: Tue May 08, 2018 2:12 am

Re: nrpe installation error(configure: error)

Postby benjaminsmith » Wed Jun 26, 2019 4:54 pm

Hello,

What operating system are you installing NRPE on and what instructions are you using?

The easiest way to install NRPE is by using the install script as it will set everything up for you.

See: NRPE - How to install NRPE

Alternatively, you can install NRPE directly from source: NRPE - How To Install NRPE v3 From Source

Regarding the errors, does you server have access to the internet? What is the output to:
Code: Select all
yum repolist
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
benjaminsmith
 
Posts: 1955
Joined: Wed Aug 22, 2018 4:39 pm
Location: saint paul

Re: nrpe installation error(configure: error)

Postby sandeep027 » Thu Jun 27, 2019 4:17 am

Thanks for responding.. please find the below output of yum repolist

-bash-4.2# yum repolist
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
file:///mnt/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /mnt/repodata/repomd.xml"
Trying other mirror.
repo id repo name status
InstallMedia Red Hat Enterprise Linux 7.5 5,099
!LocalRepo Local Repository 5,099
epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 13,242
repolist: 23,440
-bash-4.2#

I have followed the link the below link to install NRPE , but getting the same error.

https://support.nagios.com/kb/article.php?id=515#RHEL

As per link first i tried to install the below one

yum install -y gcc glibc glibc-common openssl openssl-devel perl wget

but getting below error. please check the errror as below

-bash-4.2# yum install -y gcc glibc glibc-common openssl openssl-devel perl wget
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.
file:///mnt/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /mnt/repodata/repomd.xml"
Trying other mirror.
Package gcc-4.8.5-28.el7.x86_64 already installed and latest version
Package glibc-2.17-222.el7.x86_64 already installed and latest version
Package glibc-common-2.17-222.el7.x86_64 already installed and latest version
Package 1:openssl-1.0.2k-12.el7.x86_64 already installed and latest version
Package 4:perl-5.16.3-292.el7.x86_64 already installed and latest version
Package wget-1.14-15.el7_4.1.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package openssl-devel.x86_64 1:1.0.2k-12.el7 will be installed
--> Processing Dependency: krb5-devel(x86-64) for package: 1:openssl-devel-1.0.2k-12.el7.x86_64
--> Processing Dependency: zlib-devel(x86-64) for package: 1:openssl-devel-1.0.2k-12.el7.x86_64
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.15.1-18.el7 will be installed
--> Processing Dependency: libkadm5(x86-64) = 1.15.1-18.el7 for package: krb5-devel-1.15.1-18.el7.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.15.1-18.el7.x86_64
--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.15.1-18.el7.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.15.1-18.el7.x86_64
--> Processing Dependency: libverto-devel for package: krb5-devel-1.15.1-18.el7.x86_64
---> Package zlib-devel.x86_64 0:1.2.7-17.el7 will be installed
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.5.8-3.el7 will be installed
---> Package libcom_err-devel.x86_64 0:1.42.9-11.el7 will be installed
---> Package libkadm5.x86_64 0:1.15.1-18.el7 will be installed
---> Package libselinux-devel.x86_64 0:2.5-12.el7 will be installed
--> Processing Dependency: libsepol-devel(x86-64) >= 2.5-6 for package: libselinux-devel-2.5-12.el7.x86_64
--> Processing Dependency: pkgconfig(libpcre) for package: libselinux-devel-2.5-12.el7.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.5-12.el7.x86_64
---> Package libverto-devel.x86_64 0:0.2.5-4.el7 will be installed
--> Running transaction check
---> Package libsepol-devel.x86_64 0:2.5-8.1.el7 will be installed
---> Package pcre-devel.x86_64 0:8.32-17.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================================================================
Package Arch Version Repository Size
========================================================================================================================================================================
Installing:
openssl-devel x86_64 1:1.0.2k-12.el7 InstallMedia 1.5 M
Installing for dependencies:
keyutils-libs-devel x86_64 1.5.8-3.el7 InstallMedia 37 k
krb5-devel x86_64 1.15.1-18.el7 InstallMedia 269 k
libcom_err-devel x86_64 1.42.9-11.el7 InstallMedia 31 k
libkadm5 x86_64 1.15.1-18.el7 InstallMedia 175 k
libselinux-devel x86_64 2.5-12.el7 InstallMedia 186 k
libsepol-devel x86_64 2.5-8.1.el7 InstallMedia 77 k
libverto-devel x86_64 0.2.5-4.el7 InstallMedia 12 k
pcre-devel x86_64 8.32-17.el7 InstallMedia 480 k
zlib-devel x86_64 1.2.7-17.el7 InstallMedia 50 k

Transaction Summary
========================================================================================================================================================================
Install 1 Package (+9 Dependent packages)

Total download size: 2.8 M
Installed size: 6.0 M
Downloading packages:


Error downloading packages:
libsepol-devel-2.5-8.1.el7.x86_64: [Errno 256] No more mirrors to try.
libselinux-devel-2.5-12.el7.x86_64: [Errno 256] No more mirrors to try.
krb5-devel-1.15.1-18.el7.x86_64: [Errno 256] No more mirrors to try.
1:openssl-devel-1.0.2k-12.el7.x86_64: [Errno 256] No more mirrors to try.
zlib-devel-1.2.7-17.el7.x86_64: [Errno 256] No more mirrors to try.
libverto-devel-0.2.5-4.el7.x86_64: [Errno 256] No more mirrors to try.
keyutils-libs-devel-1.5.8-3.el7.x86_64: [Errno 256] No more mirrors to try.
libcom_err-devel-1.42.9-11.el7.x86_64: [Errno 256] No more mirrors to try.
libkadm5-1.15.1-18.el7.x86_64: [Errno 256] No more mirrors to try.
pcre-devel-8.32-17.el7.x86_64: [Errno 256] No more mirrors to try.

-bash-4.2#
sandeep027
 
Posts: 31
Joined: Tue May 08, 2018 2:12 am

Re: nrpe installation error(configure: error)

Postby mcapra » Thu Jun 27, 2019 2:39 pm

It looks like all you have for configured repositories are the local installation media, EPEL, and a custom repomd.xml file that the system is unable to read from some custom mount. Is it possible that this system is trying to reference some internal repositories for your organization that were not correctly configured? Most RHEL/CentOS systems install with Base and Extras repositories enabled by default, though if this is a custom installation/image or offline instance of RHEL/CentOS those may have been disabled.
Former Nagios employee
http://www.mcapra.com/
User avatar
mcapra
 
Posts: 3587
Joined: Thu May 05, 2016 3:54 pm

Re: nrpe installation error(configure: error)

Postby sandeep027 » Fri Jun 28, 2019 2:05 am

Actually Last week OS was upgraded on this server, and post that i am facing this issues. May be they used image or cloned while upgrading OS.

Now how to resolve this Nagios issue.
sandeep027
 
Posts: 31
Joined: Tue May 08, 2018 2:12 am

Re: nrpe installation error(configure: error)

Postby tgriep » Fri Jun 28, 2019 12:18 pm

First thing to do it to clear all of the yum settings so it can refresh the data for the repo's it needs to get the packages.

Run this as root
Code: Select all
yum clean all


Then run this to see if the package can be downloaded.
Code: Select all
yum install -y openssl-devel


Also, it looks like the server is not registered with Redhat and sometimes that causes yum issues.
This system is not registered with an entitlement server. You can use subscription-manager to register.
file:///mnt/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /mnt/repodata/repomd.xml"


You may have to register the server to allow yum to download and install packages.
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.

Be sure to check out our Knowledgebase for helpful articles and solutions!
User avatar
tgriep
Madmin
 
Posts: 8413
Joined: Thu Oct 30, 2014 9:02 am

Re: nrpe installation error(configure: error)

Postby sandeep027 » Mon Jul 01, 2019 2:17 am

Thank you so much bro.. i am able to install openssl packages with the help of Linux team. Post that i have configured the Nagios monitoring and now all the monitoring services are up and running fine. Thanks for your help and Thanks to all.

Really appreciate !
sandeep027
 
Posts: 31
Joined: Tue May 08, 2018 2:12 am

Re: nrpe installation error(configure: error)

Postby scottwilkerson » Mon Jul 01, 2019 7:20 am

sandeep027 wrote:Thank you so much bro.. i am able to install openssl packages with the help of Linux team. Post that i have configured the Nagios monitoring and now all the monitoring services are up and running fine. Thanks for your help and Thanks to all.

Really appreciate !

Glad to hear it is working!

Locking thread
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 17032
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises


Return to Nagios Core

Who is online

Users browsing this forum: No registered users and 35 guests