404 Not found on trying to launch localhost/nagios

An open discussion forum for obtaining help with Nagios Core. Nagios Core users of all experience levels are welcome here. Subforum have been created for the discussion of Nagios Core and Nagios Plugin development.

NOTE: The SourceForge.net mailing lists have been deprecated in favor of this forum in order to expedite support and provide additional features not available on the old mailing list.

404 Not found on trying to launch localhost/nagios

Postby sunilkanth » Mon Aug 12, 2019 3:35 am

Hi,

I installed Nagios core and the installation was successful but when i try to launch the nagios page i get a error saying " the requested URL /nagios was not found on this server. Apache/2.4.29(Ubuntu) server at localhost port 80.
sunilkanth
 
Posts: 2
Joined: Mon Aug 12, 2019 3:26 am

Re: 404 Not found on trying to launch localhost/nagios

Postby Guyver1 » Mon Aug 12, 2019 7:35 am

have you started apache?
systemctl start httpd

If you rebooted, did you add apache to startup?
systemctl enable httpd

have you opened the firewall port?
firewall-cmd --zone-public --add-port=80/tcp --permanent
firewall-cmd --reload
Guyver1
 
Posts: 16
Joined: Tue Apr 16, 2019 4:43 am

Re: 404 Not found on trying to launch localhost/nagios

Postby scottwilkerson » Mon Aug 12, 2019 8:37 am

As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 15796
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Re: 404 Not found on trying to launch localhost/nagios

Postby sunilkanth » Mon Aug 12, 2019 9:37 pm

Yes, i did follow all the steps. I am able to see nagios running on CLI, but when i try to launch the web interface its not logging. But when i run localhost, i see the ubuntu home page, so i believe apache is up and running.
sunilkanth
 
Posts: 2
Joined: Mon Aug 12, 2019 3:26 am

Re: 404 Not found on trying to launch localhost/nagios

Postby scottwilkerson » Tue Aug 13, 2019 6:34 am

It is usually these commands that would make you not get nagios is the UI when going to /nagios

Code: Select all
sudo make install-webconf
sudo a2enmod rewrite
sudo a2enmod cgi


Then
Code: Select all
sudo systemctl restart apache2.service
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 15796
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises


Return to Nagios Core

Who is online

Users browsing this forum: Google [Bot] and 9 guests

cron