Page 1 of 1

check_ssl_cert after Update to Nagios Core 4.4.4

PostPosted: Tue Aug 13, 2019 1:21 am
by nscblauensteiner
Hy everyone,


after the Nagios core update from 4.4.3 to 4.4.4 I realized, that everytime (once a day) the check_ssl_cert Check is being
executed on my hosts with the result "SSL_CERT CRITICAL <FQDN_HOSTNAME>: No certificate returned".
The check_ssl_cert Version is 1.88.0
Even if I execute the command manually on the Nagios Server, with the parameter "-H" for hostname.
Forward and backward DNS lookups are identical, so thats OK.

After some undetermined time, the Check suddenly works on the CLI on the Nagios Server.


Thanks in advance.

Re: check_ssl_cert after Update to Nagios Core 4.4.4

PostPosted: Tue Aug 13, 2019 4:10 pm
by scottwilkerson
We aren't the developers of this plugin but I did notice there were a few others reporting this in the past on the projects github
https://github.com/matteocorti/check_ssl_cert/issues/14
https://github.com/matteocorti/check_ssl_cert/issues/53

If you are getting the same from the command line the upgrade to 4.4.4 would have to be coincidental

Re: check_ssl_cert after Update to Nagios Core 4.4.4

PostPosted: Wed Aug 14, 2019 2:47 am
by nscblauensteiner
I already took a look at those topics, but there weren't any solutions listed.

Thanks anyway.

Re: check_ssl_cert after Update to Nagios Core 4.4.4

PostPosted: Wed Aug 14, 2019 6:27 am
by scottwilkerson
nscblauensteiner wrote:I already took a look at those topics, but there weren't any solutions listed.

Thanks anyway.

Good luck!