Page 1 of 1

check_nrpe invalid packet type received from server

PostPosted: Thu Oct 31, 2019 5:13 am
by HaschkeD
Hi,
i use Nagios Core 3.2.3 and i get the error message like in the subject line.
This works fine till yesterday.
I have restart the server where the check runs….

This is my cmd:
$USER1$/check_nrpe -H $HOSTADDRESS$ -c check_vmfs_datastore_vmcbdf01 -t 60

And this the entry in the nsclient.ini:
check_vmfs_datastore_vmcbdf01=cmd /c echo scripts\check_vmfs_datastore_vmcbdf01.ps1 | PowerShell.exe -Command -

What can i do?

Regards
Dennis

Re: check_nrpe invalid packet type received from server

PostPosted: Thu Oct 31, 2019 11:46 am
by mcapra
Here's a related KB article:
https://support.nagios.com/kb/article.php?id=518

There's a section with some troubleshooting steps specific to NSClient++ that you can attempt.

Also a related forums post:
viewtopic.php?f=6&t=42993

It would also be useful to know which versions of the check_nrpe plugin and NSClient++ agent you're using.

Re: check_nrpe invalid packet type received from server

PostPosted: Thu Oct 31, 2019 3:10 pm
by mbellerue
Thanks for jumping in, Matt!

HaschkeD, did the troubleshooting doc help with your issue? Were you able to get it resolved?

Re: check_nrpe invalid packet type received from server

PostPosted: Mon Nov 04, 2019 9:42 am
by HaschkeD
Hi,
i use NSClient 0.5.2035 on a Windows Server 2016.
I set this in the [/settings/NRPE/server] section on my nsclient.ini.

payload length=8192

Then this in my NagiosQL (see attachment).

Now i get this error:
No output returned from Plugin

Strange thing is that this works and i did no changes……..
On another server this works fine.

Re: check_nrpe invalid packet type received from server

PostPosted: Tue Nov 05, 2019 8:51 am
by HaschkeD
I have implement the exact same script on another Windows 2016 Server.
Works fine….strage.

Re: check_nrpe invalid packet type received from server

PostPosted: Tue Nov 05, 2019 5:54 pm
by tgriep
What version of the check_nrpe plugin are you using?

Depending on the version, they could not accept a large size payload as you specified.
Try setting the payload to 1024 and see if that works.

Re: check_nrpe invalid packet type received from server

PostPosted: Tue Nov 05, 2019 5:58 pm
by tgriep
One more thing, add this under the NRPE settings in the nsclient.ini file.
Code: Select all
extended response = 1

Re: check_nrpe invalid packet type received from server

PostPosted: Wed Nov 06, 2019 7:24 am
by HaschkeD
We use NRPE Plugin V. 2.12.

Today i test it with the original Server...it works.
I change nothing...….strange but now it works.

Re: check_nrpe invalid packet type received from server

PostPosted: Wed Nov 06, 2019 11:51 am
by tgriep
That old version of the plugin, the buffer size was 2048.
Maybe NSClient++ just needed to be restarted.