check_snmp timeout

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

check_snmp timeout

Postby spyder133371 » Wed May 27, 2020 4:39 pm

i am using a check_snmp to check freeswitch calls i run the script manually and it connect fine no issue but when i run it from nagios itself

Plugin timed out while executing system call error

i an running Nagios 4.4.5 and naigios plusi 2.2.1


define service{
use generic-service
service_description active calls
check_command freeswitch_calls!-C XXXXXXXXXX -w 700 -c 900
max_check_attempts 3
check_interval 5
retry_interval 1
check_period 24x7
notification_interval 60
notification_period 24x7
servicegroups FS Call Count
contacts nagiosadmin
host_name LCR80


# 'check_snmp' command definition
define command{
command_name freeswitch_calls
command_line $USER1$/check_snmp -o . -H $HOSTADDRESS$ $ARG1$

from what i can tell it configure correctly but it timing out when i run it manually this is what i get

/usr/local/nagios/etc/objects# /usr/local/nagios/libexec/check_snmp -P 2c -C XXXXXXXXXXX -H XXXXXXXXX -o . -w 1 -c 2
output : SNMP CRITICAL - *6* | iso.;1;2
Posts: 2
Joined: Tue Jun 18, 2019 3:57 pm

Re: check_snmp timeout

Postby spyder133371 » Thu May 28, 2020 1:00 pm

in case any is is wondering what the issue was i did not specific wht protocol to use so it time out i had to add -P 2c ti servce.cfg
Posts: 2
Joined: Tue Jun 18, 2019 3:57 pm

Re: check_snmp timeout

Postby scottwilkerson » Thu May 28, 2020 1:12 pm

Is it working as expected now?
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
DevOps Engineer
Posts: 18462
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises

Return to Community Support

Who is online

Users browsing this forum: Majestic-12 [Bot] and 14 guests