Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA Problem

Postby Goobertek » Tue Jun 16, 2020 5:38 pm

Tried getting this to work with several combinations and syntax. Can't get it to work:


define command{
command_name check_disk_snmp
command_line $USER1$/check_disk_snmp -H $HOSTADDRESS$ -w $ARG1$ -c $ARG$

The Device.cfg:

define service{
use generic-service
host_name Pi My Life Up Host
service_description Disk_Check
check_command check_disk_snmp!!90!80!161!mycommunity!phys

I have also tried "c" instead of "phys"

Results are always the same:

(No output on stdout) stderr: execvp(/usr/local/nagios/libexec/check_disk_snmp, ...) failed. errno is 2: No such file or directory

Does anyone have advice? snmp is active on the windows 10 PC I am checking and the community is set to mycommunity.

Help :-)

Posts: 8
Joined: Wed Jun 10, 2020 5:21 pm

Return to Community Support

Who is online

Users browsing this forum: ingenieria.itoc and 28 guests