showing results differently

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

showing results differently

Postby Pratapa » Thu Jun 18, 2020 6:29 am

Following are the entries in nrpe.cfg file on the client machine host1. host1 is a Liunx Debian machine.

command[check_users]=/usr/lib/nagios/plugins/check_users -w 5 -c 10
command[check_load]=/usr/lib/nagios/plugins/check_load -w 15,10,5 -c 30,25,20
command[check_zombie_procs]=/usr/lib/nagios/plugins/check_procs -w 5 -c 10 -s Z
command[check_total_procs]=/usr/lib/nagios/plugins/check_procs -w 150 -c 200



We are getting different results when we check on host1 and on Nagios server. What could be the reason. We are using Nagios core.



root@host1:~# /usr/lib/nagios/plugins/check_users -w 5 -c 10
USERS OK - 1 users currently logged in |users=1;5;10;0
root@host1:~#
root@host1:~# /usr/lib/nagios/plugins/check_load -w 15,10,5 -c 30,25,20
OK - load average: 0.01, 0.01, 0.00|load1=0.010;15.000;30.000;0; load5=0.010;10.000;25.000;0; load15=0.000;5.000;20.000;0;
root@host1:~#
root@host1:~# /usr/lib/nagios/plugins/check_procs -w 5 -c 10 -s Z
PROCS OK: 0 processes with STATE = Z | procs=0;5;10;0;
root@host1:~#
root@host1:~# /usr/lib/nagios/plugins/check_procs -w 150 -c 200
PROCS OK: 94 processes | procs=94;150;200;0;




Following are the results from Nagios server.


.[root@Nagios libexec]# ./check_nrpe -H host1 -c check_users


Usage:
check_users -w <users> -c <users>
[root@Nagios libexec]# ./check_nrpe -H host1 -c check_load
Warning threshold must be float or float triplet!

Usage:
check_load [-r] -w WLOAD1,WLOAD5,WLOAD15 -c CLOAD1,CLOAD5,CLOAD15

[root@Nagios libexec]# ./check_nrpe -H host1 -c check_zombie_procs
PROCS WARNING: 98 processes | procs=98;Z;;0;
[root@Nagios libexec]#
[root@Nagios libexec]# ./check_nrpe -H host1 -c check_total_procs
PROCS OK: 98 processes | procs=98;;;0;
Pratapa
 
Posts: 99
Joined: Tue Oct 01, 2019 1:33 am

Re: showing results differently

Postby Pratapa » Fri Jun 19, 2020 1:36 am

This issue is resolved.

Please ignore.
Pratapa
 
Posts: 99
Joined: Tue Oct 01, 2019 1:33 am

Re: showing results differently

Postby scottwilkerson » Mon Jul 06, 2020 3:41 pm

Pratapa wrote:This issue is resolved.

Please ignore.

Great!

Locking thread
As of May 25th, 2018, all communications with Nagios Enterprises and its employees are covered under our new Privacy Policy.
User avatar
scottwilkerson
DevOps Engineer
 
Posts: 18640
Joined: Tue Nov 15, 2011 3:11 pm
Location: Nagios Enterprises


Return to Community Support

Who is online

Users browsing this forum: Google [Bot] and 10 guests