Unable to start nrpe on Linux server

Engage with the community of users including those using the open source solutions.
Includes Nagios Core, Plugins, and NCPA

Unable to start nrpe on Linux server

Postby Pratapa » Fri Jul 10, 2020 12:53 am

Hi,

We are unable to start nrpe on one of the client machines which is a Debian Linux.

root@aeafnxweb01:/etc/init.d# ./nagios-nrpe-server stop
[ ok ] Stopping nagios-nrpe-server (via systemctl): nagios-nrpe-server.service.

root@aeafnxweb01:/etc/init.d# ./nagios-nrpe-server start
[ ok ] Starting nagios-nrpe-server (via systemctl): nagios-nrpe-server.service.

root@aeafnxweb01:/etc/init.d# ./nagios-nrpe-server status
● nagios-nrpe-server.service - Nagios Remote Plugin Executor
Loaded: loaded (/lib/systemd/system/nagios-nrpe-server.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2020-07-10 14:58:49 AEST; 6s ago
Docs: http://www.nagios.org/documentation
Process: 74753 ExecStopPost=/bin/rm -f /var/run/nagios/nrpe.pid (code=exited, status=0/SUCCESS)
Process: 74733 ExecStart=/usr/sbin/nrpe -c /etc/nagios/nrpe.cfg -f $NRPE_OPTS (code=exited, status=2)
Main PID: 74733 (code=exited, status=2)
CPU: 4ms

Jul 10 14:58:49 aeafnxweb01 systemd[1]: Started Nagios Remote Plugin Executor.
Jul 10 14:58:49 aeafnxweb01 systemd[1]: nagios-nrpe-server.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
Jul 10 14:58:49 systemd[1]: nagios-nrpe-server.service: Unit entered failed state.
Jul 10 14:58:49 aeafnxweb01 systemd[1]: nagios-nrpe-server.service: Failed with result 'exit-code'.
root@aeafnxweb01:/etc/init.d#



We are unable to telnet the client machine on port 5666 from Nagios production server.

[Nagios Production server ~]$ telnet aeafnxweb01 5666
Trying 10.210.1.5...
telnet: connect to address 10.210.1.5: Connection refused
[[Nagios Production server ~]$

Services are in critical state with the following status information.

(No output on stdout) stderr: connect to address 10.110.2.5 port 5666: Connection refused


However, the server is up.

Is this because of we are uanble to telnet on 5666 that nrpe is not starting?
Pratapa
 
Posts: 97
Joined: Tue Oct 01, 2019 1:33 am

Re: Unable to start nrpe on Linux server

Postby Pratapa » Mon Jul 13, 2020 12:59 am

Awaiting reply.
Pratapa
 
Posts: 97
Joined: Tue Oct 01, 2019 1:33 am


Return to Community Support

Who is online

Users browsing this forum: hbouma and 14 guests